#25294 [Csd]: ftp_nlist fails on nai site with coredump
| From: | steveh at brendata dot co dot uk | Date: | Wed, 10 Sep 2003 11:13:32 +0000 |
| Subject: | #25294 [Csd]: ftp_nlist fails on nai site with coredump | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-47372@lists.php.net to get a copy of this message | ||
ID: 25294
User updated by: steveh at brendata dot co dot uk
Reported By: steveh at brendata dot co dot uk
Status: Closed
Bug Type: FTP related
Operating System: Linux 2.4.21
PHP Version: 4.3.4-dev
New Comment:
Confirmed, that has fixed it.
Thanks.
Previous Comments:
------------------------------------------------------------------------
[2003-09-09 17:20:35] pollita@php.net
This bug has been fixed in CVS.
In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.
In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
Thank you for the report, and for helping us make PHP better.
A developer was able to reproduce this finally and came up with a
patch. The next snapshot should work fine (give it time to be
generated). If not, please reopen.
------------------------------------------------------------------------
[2003-09-09 12:16:36] pollita@php.net
If the rebuild fails, try adding this line to the end of your script.
var_dump(ftp_close($fp));
------------------------------------------------------------------------
[2003-09-09 09:43:49] sniper@php.net
Do this:
# rm config.cache
# ./configure --disable-all --disable-cgi --enable-ftp --enable-debug
# make clean && make
And try that script again. (with the snapshot)
If it crashes, provide a backtrace.
------------------------------------------------------------------------
[2003-09-09 04:49:54] steveh at brendata dot co dot uk
Sorry, still fails, same as before:
[root@Linux3 php4-STABLE-200309081530]# ./sapi/cli/php ~/test.php
resource(4) of type (FTP Buffer)
resource(4) of type (FTP Buffer)
bool(false)
resource(4) of type (FTP Buffer)
Segmentation fault (core dumped)
[root@Linux3 php4-STABLE-200309081530]#
------------------------------------------------------------------------
[2003-09-06 09:16:51] sniper@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php4-STABLE-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-STABLE-latest.zip
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/25294
--
Edit this bug report at http://bugs.php.net/?id=25294&edit=1