Bug #14507 Updated: sessions and mm produce an error on starting apache
| From: | rider at altlinux dot ru | Date: | Sun, 17 Feb 2002 19:26:17 +0000 |
| Subject: | Bug #14507 Updated: sessions and mm produce an error on starting apache | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-475@lists.php.net to get a copy of this message | ||
ID: 14507
Updated by: rider@altlinux.ru
-Reported By: adrieder@sbox.tugraz.at
+Reported By: rider@altlinux.ru
Status: Closed
Bug Type: Session related
Operating System: Sparc/Solaris 8
PHP Version: 4.1.1
Assigned To: yohgaki
New Comment:
bug on Linux with apache-1.3.23 and mod_php 4.1.1 (with last patches
from cvs branch PHP_4_0_7):
[root@riderbook root]# ls -al /tmp/session_mm.sem
ls: /tmp/session_mm.sem: No such file or directory
[root@riderbook root]# service httpd start
Starting httpd:
[ OK ]
[root@riderbook root]# ls -al /tmp/session_mm.sem
-rw------- 1 root root 0 Feb 18 01:25
/tmp/session_mm.sem
and from user:
[rider@riderbook rider]$ php
Content-type: text/html
PHP Fatal error: Unable to start session mm module in Unknown on line
0
Previous Comments:
------------------------------------------------------------------------
[2002-01-24 23:46:52] yohgaki@php.net
Fixed in CVS.
------------------------------------------------------------------------
[2002-01-02 17:14:39] yohgaki@php.net
4.1.x disply error.... I'm working on it now. It may be fixed in 4.1.2,
if other develpers do not object my fix.
For now, set save handler to "files" and set handler to "mm" in your
script using session_module_name() if you don't like to error message.
(It does not harm any, you can ignore error message)
------------------------------------------------------------------------
[2001-12-31 11:06:37] adrieder@sbox.tugraz.at
The Problem still exists in PHP Version 4.1.1
any hints/solutions?
------------------------------------------------------------------------
[2001-12-19 23:02:03] yohgaki@php.net
I created new report for this bug which explains why this happens.
Duplicate #14612
--
Yasuo Ohgaki
------------------------------------------------------------------------
[2001-12-14 07:38:29] adrieder@sbox.tugraz.at
I did a "make distclean" and a rebuild with the following options:
./configure\
--with-mysql=/usr/local/mysql\
--with-db3 \
--enable-sysvsem\
--enable-sysvshm\
--with-mm=/usr/local\
--with-openssl \
--enable-track-vars\
--enable-trans-sid\
--enable-shmop\
--with-gd \
--with-jpeg-dir=/usr/local/lib \
--with-png-dir=/usr/local/lib \
--enable-inline-optimization \
--enable-bcmath \
--with-gettext \
--with-mcrypt \
--with-zlib \
--disable-debug \
--with-apxs=/usr/local/apache/bin/apxs
All this didn't solve the problem, I'm still getting:
PHP Fatal error: Cannot find save handler mm in Unknown on line 0
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/14507
--
Edit this bug report at http://bugs.php.net/?id=14507&edit=1