Bug #14507 Updated: sessions and mm produce an error on starting apache
| From: | yohgaki@php.net | Date: | Sun, 17 Feb 2002 23:25:30 +0000 |
| Subject: | Bug #14507 Updated: sessions and mm produce an error on starting apache | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-478@lists.php.net to get a copy of this message | ||
ID: 14507
Updated by: yohgaki@php.net
Reported By: adrieder@sbox.tugraz.at
Status: Closed
Bug Type: Session related
Operating System: Sparc/Solaris 8
PHP Version: 4.1.1
Assigned To: yohgaki
New Comment:
You have different problem.
The fix will be commited when Sascha agrees with my patch.
Previous Comments:
------------------------------------------------------------------------
[2002-02-17 14:26:17] rider@altlinux.ru
bug on Linux with apache-1.3.23 and mod_php 4.1.1 (with last patches
from cvs branch PHP_4_0_7):
[root@riderbook root]# ls -al /tmp/session_mm.sem
ls: /tmp/session_mm.sem: No such file or directory
[root@riderbook root]# service httpd start
Starting httpd:
[ OK ]
[root@riderbook root]# ls -al /tmp/session_mm.sem
-rw------- 1 root root 0 Feb 18 01:25
/tmp/session_mm.sem
and from user:
[rider@riderbook rider]$ php
Content-type: text/html
PHP Fatal error: Unable to start session mm module in Unknown on line
0
------------------------------------------------------------------------
[2002-01-24 23:46:52] yohgaki@php.net
Fixed in CVS.
------------------------------------------------------------------------
[2002-01-02 17:14:39] yohgaki@php.net
4.1.x disply error.... I'm working on it now. It may be fixed in 4.1.2,
if other develpers do not object my fix.
For now, set save handler to "files" and set handler to "mm" in your
script using session_module_name() if you don't like to error message.
(It does not harm any, you can ignore error message)
------------------------------------------------------------------------
[2001-12-31 11:06:37] adrieder@sbox.tugraz.at
The Problem still exists in PHP Version 4.1.1
any hints/solutions?
------------------------------------------------------------------------
[2001-12-19 23:02:03] yohgaki@php.net
I created new report for this bug which explains why this happens.
Duplicate #14612
--
Yasuo Ohgaki
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/14507
--
Edit this bug report at http://bugs.php.net/?id=14507&edit=1