#12995 [Csd->Opn]: "Failed opening ... in Unknown on line 0
| From: | se at brainbits dot net | Date: | Mon, 29 Sep 2003 15:53:15 +0000 |
| Subject: | #12995 [Csd->Opn]: "Failed opening ... in Unknown on line 0 | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-48260@lists.php.net to get a copy of this message | ||
ID: 12995
User updated by: se at brainbits dot net
Reported By: se at brainbits dot net
-Status: Closed
+Status: Open
Bug Type: Scripting Engine problem
Operating System: SuSE Linux 7.2
-PHP Version: 4.0.6
+PHP Version: 4.3.3
New Comment:
Again I have this problem. Now it occurs on an Debian 3.0 with PHP4.3.3
and on a SuSE 7.2 with PHP4.3.2 - both with Apache/1.3.26.
But the error-message changed a little bit:
Warning: Unknown(prepend.php4): failed to open stream: No such file or
directory in Unknown on line 0
Warning: (null)(): Failed opening 'prepend.php4' for inclusion
(include_path='.:/www/user1/inc') in Unknown on line 0
Curios: there is no auto_prepend-file and there is no script which
includes a file called "prepend.php4" in the host enviroment of user1.
There is another user with another virtual hosts who uses a
auto_prepend_file called "prepend.php4". But why does this takes effect
on the host of user 1?
Bye,
Sascha
Previous Comments:
------------------------------------------------------------------------
[2003-05-09 07:23:37] sniper@php.net
Most likely fixed already.
------------------------------------------------------------------------
[2003-04-29 11:18:34] se at brainbits dot net
Sorry, I am very busy at the moment. I think before end of may I won't
be able to test it. Please tell me if I should test it even if takes a
long time till you get the feedback.
------------------------------------------------------------------------
[2003-04-28 11:52:22] wez@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php4-STABLE-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-STABLE-latest.zip
------------------------------------------------------------------------
[2003-04-25 03:08:11] se at brainbits dot net
No, No, I can definitly negate, that this error happens when another
process chmod'd the file.
With version 4.2.3 we still have this problem. But it doesn't happens
as often as under 4.0.6.
In the meantime I can also debar, that this only happens under a load
of more than 1.0. I saw this error on systems with a load lesser than
0.2.
When this error happens, mostly it is quite enough to press the
reload-button for a few times. After three to five reloads everything
works fine.
Here is our current systems under which the error occurs:
Debian Woody 3.0 with Apache/1.3.27 and mod_php 4.2.3
------------------------------------------------------------------------
[2003-04-16 21:16:50] bishop at platypus dot bc dot ca
when I ran into this error, a bit of fiddling made me realize that
another process inadvertantly chmod'd the file. Please, se@, can you
check that if you see this again?
(not a me-too; an idea, maybe)
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/12995
--
Edit this bug report at http://bugs.php.net/?id=12995&edit=1