#10969 [Com]: apache don't start, cannot load php4apache.dll

From: Date: Sun, 19 Oct 2003 17:55:45 +0000
Subject: #10969 [Com]: apache don't start, cannot load php4apache.dll
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-49206@lists.php.net to get a copy of this message
ID: 10969 Comment by: bugs dot php dot net at solle dot net Reported By: ipcholkin at yahoo dot com Status: Bogus Bug Type: Apache related Operating System: Win 98 PHP Version: 4.0.5 New Comment: I had the same problem -- the httpd.conf syntax was fine, but php4apache.dll refused to load. Suspecting a dependency issue, I fired up Dependency Walker. Sure enough, neither of the two DLLs it relies on ... APACHECORE.DLL PHP4TS.DLL ... were in the search path. Guessing that Apache knew where to find its DLL, I copied PHP4TS.DLL alongside it, and suddenly everything started behaving. Hope that helps, Sean. Previous Comments: ------------------------------------------------------------------------ [2002-12-04 13:58:00] au_viol2002 at yahoo dot com Hi I have this problem too with apache 1.3.27, php 4.2.3 (win98) apache works alone but not apache+php "missing dll to make php4apache.dll working" it says and so php4apache.dll don't get loaded. when trying to open php.exe I had the following message: "missing odbc32.dll" I only have odbcjt32.dll on my computer, I'll to look for odbc32.dll, not found yet on internet. ------------------------------------------------------------------------ [2001-05-23 16:29:25] ipcholkin at yahoo dot com I found what the error was: Apache could not find odbc32.dll. After I installed this library the server started normally. ------------------------------------------------------------------------ [2001-05-21 09:36:13] ipcholkin at yahoo dot com I don't see any sintax error there. Please send detailed info. I think scripting engine classifies this as a sintax error but indeed there are another kind of a problem. By the way, the full message I see in my console window is: "Syntax error on line 979 of k:/apache/apache/conf/httpd.conf: Cannot load k:/apache/apache/modules/mod_php4/sapi/php4apache.dll into server: (1157) Cannot load dinamic library:" The last sentence was written in russian, in accordance with OS-specific regional settings and then translated by me in English. That's why I omitted this message in the first edition of this bug report. ------------------------------------------------------------------------ [2001-05-19 10:50:01] jmoore@php.net Bogus ------------------------------------------------------------------------ [2001-05-19 10:44:27] jmoore@php.net This is not a bug in PHP. You have made a mistake in your httpd.conf on line 979. fix this syntax error and try again. ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/10969 -- Edit this bug report at http://bugs.php.net/?id=10969&edit=1

« previous php.bugs (#49206) next »