#26081 [Opn->Fbk]: Broken pipo by incomplete headers
ID: 26081
Updated by: edink@php.net
Reported By: php at searchystats dot com
-Status: Open
+Status: Feedback
Bug Type: CGI related
Operating System: FreeBSD 4.8
PHP Version: 4.3.4RC3
New Comment:
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php
If you can provide more information, feel free to add it
to this bug and change the status back to "Open".
Thank you for your interest in PHP.
Previous Comments:
------------------------------------------------------------------------
[2003-11-02 11:51:58] php at searchystats dot com
Description:
------------
The problem is that php as FastCGI application occasionaly fails and
produces this error log:
[Sun Nov 2 17:40:17 2003] [error] [client %ip%] (32)Broken pipe:
FastCGI: comm with server "/opt/guide/ppi.searchy.net/cgi-bin/php.fcgi"
aborted: write failed
[Sun Nov 2 17:40:17 2003] [error] [client %ip%] FastCGI: incomplete
headers (0 bytes) received from server
"/opt/guide/ppi.searchy.net/cgi-bin/php.fcgi"
/opt/guide/ppi.searchy.net/cgi-bin/php.fcgi = the binary php compiled
with the following configure command:
./configure --without-apache --enable-fastcgi
--enable-force-cgi-redirect --prefix=/usr/local/php-4.3.4RC3-test
--with-mysql=/usr/local/mysql --with-openssl
I have not been able to reproduce the problem, it justs occures now and
then. The apache configuration is as follows specific to php fastcgi in
a virtualhost directive:
FastCgiServer /opt/guide/ppi.searchy.net/cgi-bin/php.fcgi
-appConnTimeout 0 -processes 5 -listen-queue-depth 100 -flush
FastCgiConfig -maxProcesses 50 -minProcesses 6 -appConnTimeout 0
AddHandler php-fastcgi .fphp .php4 .php3 .php
Action php-fastcgi /cgi-bin/php.fcgi
Reproduce code:
---------------
*any source code*
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=26081&edit=1
Thread (4 messages)