#26537 [NEW]: Unable to run PHP5 when web-server started as a NT service
| From: | andrey at cherezov dot koenig dot su | Date: | Sat, 06 Dec 2003 09:49:55 +0000 |
| Subject: | #26537 [NEW]: Unable to run PHP5 when web-server started as a NT service | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-51741@lists.php.net to get a copy of this message | ||
From: andrey at cherezov dot koenig dot su
Operating system: Windows XP
PHP version: 5.0.0b2 (beta2)
PHP Bug Type: CGI related
Bug description: Unable to run PHP5 when web-server started as a NT service
Description:
------------
When I run php5.exe as a CGI from a web-server running as ordinal program
(not a service) - php5 works perfect. If I start the same web-server as NT
service and run CGI (php5.exe) with the same parameters again - php5.exe
did not produce any output at all, just finished.
php4.exe (any version) works OK in this web-server both in service mode
and ordinal app mode.
Reproduce code:
---------------
PhpInfo();
Expected result:
----------------
PHP Version 5.0.0b2
System Windows NT CHEREZOV 5.1 build 2600
Build Date Oct 30 2003 12:34:01
Server API CGI/FastCGI
Virtual Directory Support enabled
Configuration File (php.ini) Path G:\WINXP\php.ini
PHP API 20030820
PHP Extension 20020429
Zend Extension 90021012
Debug Build no
Thread Safety enabled
Registered PHP Streams php, file, http, ftp, compress.zlib
...
(This text displayed if I run php5.exe from NON service web-server).
--
Edit bug report at http://bugs.php.net/?id=26537&edit=1
--
Try a CVS snapshot (php4): http://bugs.php.net/fix.php?id=26537&r=trysnapshot4
Try a CVS snapshot (php5): http://bugs.php.net/fix.php?id=26537&r=trysnapshot5
Fixed in CVS: http://bugs.php.net/fix.php?id=26537&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=26537&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=26537&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=26537&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=26537&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=26537&r=support
Expected behavior: http://bugs.php.net/fix.php?id=26537&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=26537&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=26537&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=26537&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=26537&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=26537&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=26537&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=26537&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=26537&r=float