#26324 [Fbk->NoF]: PHP SAPI fails to load files in different encoding

From: Date: Sun, 07 Dec 2003 17:01:13 +0000
Subject: #26324 [Fbk->NoF]: PHP SAPI fails to load files in different encoding
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-51775@lists.php.net to get a copy of this message
 ID:               26324
 Updated by:       sniper@php.net
 Reported By:      vitaly at inside dot rtcomm dot ru
-Status:           Feedback
+Status:           No Feedback
 Bug Type:         *URL Functions
 Operating System: Windows XP
 PHP Version:      4.3.4
 New Comment:

No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.




Previous Comments:
------------------------------------------------------------------------

[2003-12-01 03:16:36] sniper@php.net

Huh? What SAPI?


------------------------------------------------------------------------

[2003-11-25 07:16:37] vitaly at lcc dot chem dot msu dot ru

This is WINDOWS-1251 (Russian text).
I cann't understand why it does not work with SAPI under (WINDOWS).
It correctly works with CGI(WINDOWS) and SAPI(FreeBSD)!

------------------------------------------------------------------------

[2003-11-25 04:26:21] sniper@php.net

And exactly what might that encoding be..?


------------------------------------------------------------------------

[2003-11-19 16:28:25] vitaly at inside dot rtcomm dot ru

Description:
------------
The problem under Windows XP:
-----------------------------------------
Warning: Unknown(C:\WebRoot\%D0%B8%D0%BD%D0%B4%D0%B5%D0%BA%D1%81.php):
failed to open stream: No such file or directory in Unknown on line 0

Warning: (null)(): Failed opening
'C:\WebRoot\%D0%B8%D0%BD%D0%B4%D0%B5%D0%BA%D1%81.php' for inclusion
(include_path='.;c:\php\includes') in Unknown on line 0
--------------------------------------------
   When I download the file %D0%B8%D0%BD%D0%B4%D0%B5%D0%BA%D1%81.txt
Apache (2.0.48) correctly send it to me. 
   But PHP(4.3.4) SAPI send me this error, instead of the correct
result. 
   Filemon shows that php(and no other program) do not touch this file
at all. 
   (!) Php works correctly with this file under FreeBSD in the same
conditions.

Expected result:
----------------
PHP must execute that file.



------------------------------------------------------------------------


-- 
Edit this bug report at http://bugs.php.net/?id=26324&edit=1


Thread (5 messages)

« previous php.bugs (#51775) next »