Bug #16666 Updated: Ask for re-naming DOM XML extension functions according to W3C DOM
| From: | robert at webmotion dot com | Date: | Wed, 17 Apr 2002 20:17:33 +0000 |
| Subject: | Bug #16666 Updated: Ask for re-naming DOM XML extension functions according to W3C DOM | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-5232@lists.php.net to get a copy of this message | ||
ID: 16666
Updated by: robert@webmotion.com
Reported By: stepan.rybar@ceu.cz
Status: Closed
Bug Type: Feature/Change Request
Operating System: MS Win2000 (not important)
PHP Version: 4.2.0
New Comment:
justToBeArgumentativeSinceThisIsMyPreferredStyle rather than the
fy_i_v_lwwds_t style ;)
addSlashes()
htmlEntities()
quoteMeta()
stripSlashes()
ucWords()
wordWrap()
imageCreate()
imageFill()
rawUrlEncode()
And while I know these are all probably encoded as lowercase and the
fact they can be uppercased is merely that functions are insensitive, I
do believe that it makes the point :)
Cheers,
Rob.
Previous Comments:
------------------------------------------------------------------------
[2002-04-17 16:07:19] mfischer@php.net
Unlikely to happen.
This would break 1000² of scripts.
I hope you know what I mean.
OTOH, IMHO that's just syntentic sugar. Many people do not like to read
in StUYcApS and find this_style_easier_to_read.
And, it's the PHP naming convention to use_this_style.
I bet you're out of luck.
------------------------------------------------------------------------
[2002-04-17 14:01:31] stepan.rybar@ceu.cz
Hello!
I like to see DOM XML extension in PHP. I often use it in browser's
(client-side) programming using JavaScript, so I am surprised, why the
functions of this extension is named as today. It is a confusing for me
and think not only form me. According to W3C DOM standards functions
looks like "getAttribute" and not "get_attribute" etc. I hope, that You
know what I mean.
Thank You.
Steve
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=16666&edit=1