#26942 [Opn]: mod_php randomly displays source instead of script output
| From: | stephan dot gloor at gli dot ch | Date: | Sat, 17 Jan 2004 10:38:57 +0000 |
| Subject: | #26942 [Opn]: mod_php randomly displays source instead of script output | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-53476@lists.php.net to get a copy of this message | ||
ID: 26942
User updated by: stephan dot gloor at gli dot ch
Reported By: stephan dot gloor at gli dot ch
Status: Open
Bug Type: Apache related
Operating System: Linux 2.4.20
PHP Version: 4.3.4
New Comment:
In the mean time I found
http://bugs.php.net/bug.php?id=25753
and try this.
If there's another workaround please tell me.
We use confixx which generates VirtualHost entries with
- php_admin_flag engine off
- php_admin_value open_basedir /usr/local/httpd/htdocs/kunden/web1/
entries.
If this is not acceptable für php we can't use confixx anymore !!!
What happens when the following settings are made outside VirtualHost
entries ? Does this lead to the same bug ?
php_admin_flag safe_mode On
php_admin_value safe_mode_exec_dir
/usr/local/httpd/htdocs/kunden/empty
Thanks and regards,
Stephan
Previous Comments:
------------------------------------------------------------------------
[2004-01-17 05:16:59] stephan dot gloor at gli dot ch
Description:
------------
Hello
I get the same error as described in
http://bugs.php.net/bug.php?id=22480
but the update to php 4.3.4 didn't help.
It happens on Apche 2 as well as Apache.
Is there a way to get more information out of the log file. Until now,
I couldn't find any entry in the php log file for the errornous request
Thanks and regards for any hint
Stephan
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=26942&edit=1