Bug #14594 Updated: Failed to compile/run when using Apache 2.x, unresolved symbols

From: Date: Fri, 19 Apr 2002 15:36:19 +0000
Subject: Bug #14594 Updated: Failed to compile/run when using Apache 2.x, unresolved symbols
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-5401@lists.php.net to get a copy of this message
ID: 14594 Updated by: aaron@php.net Reported By: juraj@bednar.sk -Status: Open +Status: Closed Bug Type: Apache2 related Operating System: FreeBSD 4.4-STABLE PHP Version: 4.1.0 New Comment: This bug has already been fixed in the latest released version of PHP, which you can download at http://www.php.net/downloads.php The apache2filter is known to work with Apache 2.0.35 and either CVS HEAD or the 4.2.0 branch (or the latest release candidate). Please report back if you have any problems related to FreeBSD 4.x and these versions. Previous Comments: ------------------------------------------------------------------------ [2002-04-15 16:30:23] klansman@arrakis.dhis.org My installation worked! installed gnu pth and used --with-tsrm-pth=/usr/local/libs/pth in the configure script. Note that this is warned in the end of the configure process. [] ------------------------------------------------------------------------ [2002-04-15 09:36:17] josh@lokot.com Same results on FreeBSD 4.2-RELEASE with Apache 2.0.35 / PHP 4.2.0RC4 ------------------------------------------------------------------------ [2002-04-15 08:15:12] tino@tino.nl Exactly the same error here. FreeBSD 4.5 / Release Apache 2.0.35 PHP 4.2.0RC4 Tried: ./configure --with-apache=/usr/local/apache2/bin/apxs --with-tsrm-pth Didn't work: ./apachectl configtest Syntax error on line 217 of /usr/local/apache2/conf/httpd.conf: Cannot load /usr/local/apache2/modules/libphp4.so into server: /usr/local/apache2/modules/libphp4.so: Undefined symbol "pthread_getspecific" ------------------------------------------------------------------------ [2002-04-14 19:30:10] klansman@arrakis.dhis.org i had the same problem. using freebsd 4.5, apache 2.0.25, php 4.2.0RC3 trying with gnu-pth ------------------------------------------------------------------------ [2002-04-07 11:42:12] gnusy@option-fr.com Same problem still on FreeBSD4.5 tested with: apache cvs 2.0.36 with php4.2.0RC2 apache cvs 2.0.36 with last php cvs (update on 7/04) apache release 2.0.35 with php4.2.0RC apache release 2.0.35 with last php cvs finally works with using trsm-pth with in php configure. ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/14594 -- Edit this bug report at http://bugs.php.net/?id=14594&edit=1

« previous php.bugs (#5401) next »