#27077 [Opn->Fbk]: Changing 'mssql.textsize' in php.ini causes connections to stop working
ID: 27077
Updated by: sniper@php.net
Reported By: jason at burfield dot com
-Status: Open
+Status: Feedback
Bug Type: MSSQL related
Operating System: Linux ( Suse 9 )
PHP Version: 4.3.4
New Comment:
Please try using this CVS snapshot:
http://snaps.php.net/php4-STABLE-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-STABLE-latest.zip
Previous Comments:
------------------------------------------------------------------------
[2004-01-28 12:57:13] jason at burfield dot com
Description:
------------
PHP, configured as such:
'./configure' '--with-mssql=/usr/local' '--with-apxs=/usr/sbin/apxs'
'--with-mcrypt=/usr/local' '--enable-trans-id'
Use Suse 9.0
Using Apache 1.3.28
Using FreeTDS.
I encountered a problem with the 'textsize' and 'textlimit' values in
the PHP.INI file when using SQL Server.
If left to their default values (commented out) everything is fine,
however, when I change the value to a larger size, in this case up to
10000, Apache starts and all seems fine, however, connecting to the SQL
Server database machine stops working.
If I change the limit back to default the connections start working
again.
I also attempted changing the settings in freetds.conf, however, that
had no effect at all.
Reproduce code:
---------------
/* simple connection */
$host = 'server:1433';
$user = 'username';
$pass = 'password';
$dblink = mssql_connect($host, $user, $pass);
This fails when the 'textsize' or 'textlimit' values are changed from
defaults.
Expected result:
----------------
Expect a connection to the database server to be made.
Actual result:
--------------
Connection to database server fails.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=27077&edit=1
Thread (4 messages)