#26608 [Asn]: Sporadic -439 errors on ifx_connect()
| From: | gemery at bmihs dot co dot uk | Date: | Mon, 09 Feb 2004 10:43:33 +0000 |
| Subject: | #26608 [Asn]: Sporadic -439 errors on ifx_connect() | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-54607@lists.php.net to get a copy of this message | ||
ID: 26608
User updated by: gemery at bmihs dot co dot uk
Reported By: gemery at bmihs dot co dot uk
Status: Assigned
Bug Type: Informix related
Operating System: RedHat Linux 8
-PHP Version: 4CVS-2003-12-15
+PHP Version: 4.3.3
Assigned To: nobbie
New Comment:
I'm afraid that due to excessive downtime we've been forced to move
away from php for the next version of our casetracking software :( The
boss pulled the plug and insisted we move to jsps instead. A sad day.
Thanks for a great product (apart from the unfortunate Informix issue).
Maybe if we change db we might move back to php.
Previous Comments:
------------------------------------------------------------------------
[2004-01-12 07:04:33] sniper@php.net
Assigned to the ext/informix maintainer, Corne'.
------------------------------------------------------------------------
[2003-12-17 09:57:25] gemery at bmihs dot co dot uk
OK.. Having the installed the new sdk and the snapshot (as suggested),
the system ran fine for two days.
On the third day, these three errors occurred:
[error] PHP Warning: ifx_query(): Set connection connec83 fails (E
[SQLSTATE=IX 000 SQLCODE=-439]) in
/var/www/html/casetrack/searchresult.php on line 0
[error] PHP Warning: ifx_query(): Set connection connec80 fails (E
[SQLSTATE=IX 000 SQLCODE=-439]) in
/var/www/html/casetrack/searchresult.php on line 0
[error] PHP Warning: ifx_query(): Set connection connec1 fails (E
[SQLSTATE=IX 000 SQLCODE=-439]) in
/var/www/html/casetrack/searchresult.php on line 0
After this, any attempt to use ifx_connect() resulted in this error:
[error] PHP Warning: ifx_connect(): E [SQLSTATE=IX 000 SQLCODE=-439]
in /var/www/html/casetrack/login.php on line 60
A restart of apache seemed to resolve the issue temporarily, but the
problem recurs after a (random) amount of time.
Any help/suggestions would be appreciated as the new sdk doesn't seem
to solve the issue.
------------------------------------------------------------------------
[2003-12-14 20:37:12] sniper@php.net
According to bug #14254, the newer informix sdk should fix this.
------------------------------------------------------------------------
[2003-12-12 17:39:36] gemery at bmihs dot co dot uk
OK... I'm installing this on my live system as that is the only way to
reproduce this problem. In addition I have a new version of the
informix sdk (clientsdk.2.81.UC2X5.LINUX.tar). I'll have to wait a few
days before I can report whether this has resolved the issue.
As for a short script to reproduce the problem, I'm afraid that's not
possible.
------------------------------------------------------------------------
[2003-12-12 14:08:50] magnus@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php4-STABLE-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-STABLE-latest.zip
If it still doesn't work with lastest snapshot, please provide a short
script to reproduce the problem.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/26608
--
Edit this bug report at http://bugs.php.net/?id=26608&edit=1