#27222 [NEW]: The memory could not be read.
| From: | Felipe dot Dragan at Americas dot ING dot com | Date: | Wed, 11 Feb 2004 20:00:22 +0000 |
| Subject: | #27222 [NEW]: The memory could not be read. | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-54774@lists.php.net to get a copy of this message | ||
From: Felipe dot Dragan at Americas dot ING dot com
Operating system: Windows 2000 Server SP4
PHP version: 4.3.4
PHP Bug Type: IIS related
Bug description: The memory could not be read.
Description:
------------
I´ve installed IIS 5 on a Windows 2000 Server SP4. I´ve ran IISlockdown
tool from microsoft.On this new server, I´ve installed MySQL and PHP
4.3.3. I´ve moved my intranet sites into this server, and copy exactly the
sites config from the old server (Windows NT Server 4.0 SP6a, running IIS
3 from Windows NT Option Pack, with IIS LockDown).
The problem occurs when I try to access either one of my intranet sites,
the new server displays this message in a Error Window:
<< "The instruction at "0x100..." referenced memory at "0x0000....".
The
memory could not be "read"". Click on OK to terminate the program.>>
And in client browser appears this message (only when you close this error
window in server):
<<CGI Error
The specified CGI application misbehaved by not returning a complete set
of HTTP headers. The headers it did return are:
>>
Also, if you don´t click OK in server error windows, you´ll get a CGI
timeout.
This error occurs with any file with the extension .php. I´ve tried with
the simple phpinfo() page.
What can i do to get this running. I´ve tried upgrading php version to
4.3.4, but i´ve unfortunately i´ve got the same error message.
Thanx
Reproduce code:
---------------
<?php
phpinfo();
?>
Expected result:
----------------
I except to see my intranet working
Actual result:
--------------
CGI Error
The specified CGI application misbehaved by not returning a complete set
of HTTP headers. The headers it did return are:
CGI Timeout
The specified CGI application exceeded the allowed time for processing.
The server has deleted the process.
--
Edit bug report at http://bugs.php.net/?id=27222&edit=1
--
Try a CVS snapshot (php4): http://bugs.php.net/fix.php?id=27222&r=trysnapshot4
Try a CVS snapshot (php5): http://bugs.php.net/fix.php?id=27222&r=trysnapshot5
Fixed in CVS: http://bugs.php.net/fix.php?id=27222&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=27222&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=27222&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=27222&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=27222&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=27222&r=support
Expected behavior: http://bugs.php.net/fix.php?id=27222&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=27222&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=27222&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=27222&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=27222&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=27222&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=27222&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=27222&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=27222&r=float