Bug #15333 Updated: strndup access violation
| From: | llowry at novell dot com | Date: | Sun, 21 Apr 2002 10:32:45 +0000 |
| Subject: | Bug #15333 Updated: strndup access violation | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-5498@lists.php.net to get a copy of this message | ||
ID: 15333
Updated by: llowry@novell.com
Reported By: david@harksystems.com
Status: Critical
Bug Type: IIS related
Operating System: Windows 2000 Pro
PHP Version: 4.2.0 RC2
New Comment:
I tried setting the app protection to 'Low (IIS Process)' and still get
the error. And I tried killing inetinfo.exe and running the net stop
commands from the command line, but Windows won't kill the process.
This issue has turned out to be the biggest reason my I haven't
embraced PHP yet -- because I hate rebooting my machine all of the
time.
I would love to hear of a workaround that works, and better yet, see a
published fix. Any more ideas out there?
Previous Comments:
------------------------------------------------------------------------
[2002-04-17 15:19:04] marcus.b.brock@lmco.com
I am getting this error with 4.2.0 RC2. I upgraded from 4.1.2 to 4.2.0
RC2 (both ISAPI) because 4.1.2 wasn't handling sessions correctly.
I tried setting the app protection to 'Low (IIS Process)' and all I
received were 'Invalid access to memory location' errors.
PHP 4.2.0 RC2 (ISAPI)
IIS5
Win2K Pro SP2
PIII 733MHz
384 MB RAM
------------------------------------------------------------------------
[2002-04-17 01:29:45] jim.borowicz@amivisions.com
I am also receiving this error with:
Win2k Server SP2 w/all security patches
But I am running PHP 4.1.2 ISAPI under IIS 5.0
Thanks.
------------------------------------------------------------------------
[2002-04-09 08:14:55] develop@dnet.net
I have been super busy lately, but, since I switched the app protection
down to 'Low (IIS Process)' a week ago I haven't gotten a single error
or lock up. Thanks for your persistance.
Still using 4.1.2.
------------------------------------------------------------------------
[2002-04-08 12:04:38] jtate@php.net
Ok. It definitely happens with RC2. You can restart IIS without
rebooting, you've got to perform the following:
kill the inetinfo.exe process using the task manager
run from command line:
net stop w3svc
net stop iisadmin
net start iisadmin
net start w3svc
Marking this bug critical because it should be fixed before 4.2.0
release. Still looking for fix.
------------------------------------------------------------------------
[2002-04-05 12:38:03] jtate@php.net
Nevermind. That's not the problem. Still looking.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/15333
--
Edit this bug report at http://bugs.php.net/?id=15333&edit=1