#26931 [Dup->Bgs]: odbc_pconnect has connection problems after SAP DB is restarted
| From: | sniper@php.net | Date: | Tue, 17 Feb 2004 04:48:58 +0000 |
| Subject: | #26931 [Dup->Bgs]: odbc_pconnect has connection problems after SAP DB is restarted | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-55049@lists.php.net to get a copy of this message | ||
ID: 26931
Updated by: sniper@php.net
Reported By: tobias dot barth at web-arts dot de
-Status: Duplicate
+Status: Bogus
Bug Type: *Database Functions
Operating System: SuSE linux 8.2
PHP Version: Irrelevant
New Comment:
duplicate status is deprecated.
Previous Comments:
------------------------------------------------------------------------
[2004-01-16 09:13:53] kalowsky@php.net
duplicate of 20298
------------------------------------------------------------------------
[2004-01-16 05:18:08] tobias dot barth at web-arts dot de
Description:
------------
A project that uses odbc_pconnect to connect to an Sap DB 7.4 database,
gets connection errors after the database was shut down and restarted,
but the web server (with php module) is not restarted. The problem does
not occur with odbc_connect (without p).
I think the problem could be that php thinks the connections that were
opened before the database was shut down are still open, and it does
not try to open a new connection if the old one fails.
It should recognize the old connection as closed and open a new one,
and only if this attempt fails, report the error to the application
and/or the user.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=26931&edit=1