#27348 [Opn->Fbk]: Apache won't start with PHP extensions
| From: | helly@php.net | Date: | Sun, 22 Feb 2004 23:57:25 +0000 |
| Subject: | #27348 [Opn->Fbk]: Apache won't start with PHP extensions | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-55331@lists.php.net to get a copy of this message | ||
ID: 27348
Updated by: helly@php.net
Reported By: sergeys at avalon dot ru
-Status: Open
+Status: Feedback
Bug Type: Apache related
Operating System: Windows XP En
PHP Version: 5.0.0b4 (beta4)
New Comment:
Please try using this CVS snapshot:
http://snaps.php.net/php5-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php5-win32-latest.zip
Previous Comments:
------------------------------------------------------------------------
[2004-02-22 08:50:45] sergeys at avalon dot ru
Description:
------------
I use Apache 1.3.29 on Windows XP (Apache used as a service) with
PHP5b4 as Apache module. Everything goes right until I try to use any
extension (tested with php_mysql.dll and some other). In that case
Apache won't start and OS shows Error Reporting Window with info, that
error occurs in Apache.exe in module php5ts.dll (sorry, didn't write
down the memory offset value).
Sometimes it helps taking the following actions:
1. comment the "extension=..." line
2. start Apache (it starts normally with no PHP extensions)
3. uncomment the "extension=..." line
4. restart (NOT stop then start) Apache (everything goes right,
phpinfo() shows "PHP 5 beta 4" used and MySQL extension loaded).
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=27348&edit=1