#24621 [Com]: Unable to load php_mysql.dll - The specified procedure could not be found
| From: | gerrykwan at netvigator dot com | Date: | Tue, 23 Mar 2004 19:27:29 +0000 |
| Subject: | #24621 [Com]: Unable to load php_mysql.dll - The specified procedure could not be found | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-56690@lists.php.net to get a copy of this message | ||
ID: 24621
Comment by: gerrykwan at netvigator dot com
Reported By: eric at cosky dot com
Status: Bogus
Bug Type: MySQL related
Operating System: Windows XP SP 1
PHP Version: 5CVS-2003-07-12 (dev)
New Comment:
Could you please explain the solution a little bit more?
I cannot figure out it, where should the libmySQL.dll be placed?
Previous Comments:
------------------------------------------------------------------------
[2003-07-12 16:22:03] eric at cosky dot com
Thanks for the quick suggestion!
That wasn't quite the problem, but close enough to give me a clue for
what to look for. After I verified the DLL was in fact being loaded, I
was able to determine that the DLL being loaded wasn't the correct
version - I had a DLL from a previous version of PHP lingering in my
windows/system32 folder that was getting found in the search path
before the current version.
Once again I am reminded of why I should never copy DLLs to the windows
directory and instead just update global path search variables so I
don't have old versions lurking about like this.
Thanks again,
Eric Cosky
------------------------------------------------------------------------
[2003-07-12 13:22:49] philip@php.net
Be sure to also copy libmySQL.dll to the appropriate location (like you
do with every other DLL in the dlls/ folder).
------------------------------------------------------------------------
[2003-07-12 12:44:09] eric at cosky dot com
Description:
------------
Using PHP snapshot file from today: php5-win32-200307121430.zip
PHP appears to be installed and working, except when I tried to use
phpMyAdmin with it where phpMyAdmin started saying that mysql support
wasn't enabled. Looking into it further, php_info() does not show any
mysql extensions enabled. I haven't seen it clearly stated that mysql
needs to be explicitly loaded now in php version 5.0 but it has been
implied in a couple places so I think the thing to do was add the
following line to php.ini:
extension=php_mysql.dll
When starting php, this dialog box comes up:
"Unknown(): Unable to load dynamic library
'C:\php\extensions\php_mysql.dll' - The specified procedure could not
be found"
This seems like it is what I need to be doing, and the result seems
possibly due to a bug.
Thanks for any info,
Eric Cosky
Reproduce code:
---------------
<?php php_info(); ?>
Expected result:
----------------
I expect to see mysql extensions described along with everything else.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=24621&edit=1