#4307 [Fbk->NoF]: OCILogon often causes ORA-12154 TNS error
| From: | iliaa@php.net | Date: | Tue, 23 Mar 2004 23:19:33 +0000 |
| Subject: | #4307 [Fbk->NoF]: OCILogon often causes ORA-12154 TNS error | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-56727@lists.php.net to get a copy of this message | ||
ID: 4307
Updated by: iliaa@php.net
Reported By: chris_milner at hotmail dot com
-Status: Feedback
+Status: No Feedback
Bug Type: Oracle related
Operating System: Sun Solaris 5.7
PHP Version: 4.0 Release Candidate 1
Previous Comments:
------------------------------------------------------------------------
[2004-03-16 03:45:39] tony2001@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php4-STABLE-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-STABLE-latest.zip
------------------------------------------------------------------------
[2004-03-13 11:43:32] phpdotnet dot hannes at erven dot at
I experienced exactly the same problem.
We had approx. 50% ORA-12541 and 50% "good" connects with an uppercase
SID, and the problem seems to vanish if you specify an all-lowercase
SID.
------------------------------------------------------------------------
[2000-05-13 08:03:41] thies at cvs dot php dot net
please set all oracle-relates environment variables *before* you start
your apache process! do not use SetEnv in httpd.conf not PutEnv() in
your php-script to set eny of those!
------------------------------------------------------------------------
[2000-05-03 11:14:58] chris_milner at hotmail dot com
When the Apache server is rebooted, this OCILogon call works. After a
few attempts, it fails with the error message below:
Warning: _oci_open_server: ORA-12154: TNS:could not resolve service
name in /opt/www/shopsmart/uk/htdocs/connect_test.html on line 12
connect_test.html just has a simple OCILogon call to the database. The
client and server Oracle software is set up with Net8 and works fine,
it's only from the browser the error occurs. No tracing is produced at
the Net8 level for the error.
If I leave a refresh for a minute or so, it will reconnect OK, but if I
try and reconnect frequently, I always get the error message. Oracle
Support seem to be washing their hands of this, can anyone give me any
help.
Regards
Chris
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=4307&edit=1