Bug #15333 Updated: strndup access violation

From: Date: Tue, 23 Apr 2002 22:35:20 +0000
Subject: Bug #15333 Updated: strndup access violation
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-5735@lists.php.net to get a copy of this message
ID: 15333 Updated by: develop@dnet.net Reported By: david@harksystems.com Status: Critical Bug Type: IIS related Operating System: Windows 2000 Pro PHP Version: 4.2.0 RC2 New Comment: how do I go about running 'tkill'? Previous Comments: ------------------------------------------------------------------------ [2002-04-22 19:26:53] mail-php.net@kimihia.org.nz There is a tool called "tkill" / kill / tlist that will let you terminate processes. Get the PID from tlist or Task Manager and then run kill with the PID for the argument. inetinfo.exe will be running under a different user that Administrator does not have the power to kill the processes of, so using Task Manager to kill inetinfo.exe is a waste of time. ------------------------------------------------------------------------ [2002-04-21 06:32:35] llowry@novell.com I tried setting the app protection to 'Low (IIS Process)' and still get the error. And I tried killing inetinfo.exe and running the net stop commands from the command line, but Windows won't kill the process. This issue has turned out to be the biggest reason my I haven't embraced PHP yet -- because I hate rebooting my machine all of the time. I would love to hear of a workaround that works, and better yet, see a published fix. Any more ideas out there? ------------------------------------------------------------------------ [2002-04-17 15:19:04] marcus.b.brock@lmco.com I am getting this error with 4.2.0 RC2. I upgraded from 4.1.2 to 4.2.0 RC2 (both ISAPI) because 4.1.2 wasn't handling sessions correctly. I tried setting the app protection to 'Low (IIS Process)' and all I received were 'Invalid access to memory location' errors. PHP 4.2.0 RC2 (ISAPI) IIS5 Win2K Pro SP2 PIII 733MHz 384 MB RAM ------------------------------------------------------------------------ [2002-04-17 01:29:45] jim.borowicz@amivisions.com I am also receiving this error with: Win2k Server SP2 w/all security patches But I am running PHP 4.1.2 ISAPI under IIS 5.0 Thanks. ------------------------------------------------------------------------ [2002-04-09 08:14:55] develop@dnet.net I have been super busy lately, but, since I switched the app protection down to 'Low (IIS Process)' a week ago I haven't gotten a single error or lock up. Thanks for your persistance. Still using 4.1.2. ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/15333 -- Edit this bug report at http://bugs.php.net/?id=15333&edit=1

« previous php.bugs (#5735) next »