#27827 [Csd]: Unlean shutdown apache 2.0.49 + mod_php after starting by hand
| From: | kvo at apachefriends dot org | Date: | Sat, 03 Apr 2004 08:11:56 +0000 |
| Subject: | #27827 [Csd]: Unlean shutdown apache 2.0.49 + mod_php after starting by hand | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-57426@lists.php.net to get a copy of this message | ||
ID: 27827
User updated by: kvo at apachefriends dot org
Reported By: kvo at apachefriends dot org
Status: Closed
Bug Type: Apache2 related
Operating System: windows 2000 + xp
PHP Version: 4.3.5
New Comment:
Okay, that is normal. But not only me have that problem with the
current release 4.3.5! All 4.x.x. versions are okay, the newest
developer version 4.3.6-dev too, but NOT the CURRENT RELEASE! I try it
today (as modul with start apache2 by hand, surfing php in localhost,
then shutdown apache2) and ... unclean shutdown because memory fault.
Using XP Professional and 2000 + the official binary httpd 2.0.49. So
only the current release makes that problem. Please help! I have used
PHP 4.3.5 win32 as zip from following mirrors:
www.php.net Web Hosting Talk
us2.php.net Hurricane Electric
de.php.net @GLOBE GmbH
And this email to apachefriends.org:
Apache 2.0.49 unclean shutdown after upgrade to php 4.3.5
Hello!
Thank you for XAMPP 1.4 for Windows. I'm running it on Windows XP as a
service. Please tell me why, after upgrading to php 4.3.5 from 4.3.4,
Apache.exe returns an application error, with logged error as follows:
Terminating on signal SIGTERM(15)
[Sun Mar 28 20:56:25 2004] [warn] pid file
C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of
previous Apache run?
I appreciate your work with Apache/PHP/MySQL. Please help if you can.
Thank you,
...
Previous Comments:
------------------------------------------------------------------------
[2004-04-01 16:49:13] derick@php.net
After we released 4.3.5 we moved to 4.3.6-dev which is the start of
4.3.6. We also just released 4.3.6RC1 which has this fix too. Please
test it one more time to be sure!
(Closing bug report)
------------------------------------------------------------------------
[2004-04-01 16:47:06] kvo at apachefriends dot org
http://snaps.php.net/win32/php4-win32-STABLE-latest.zip
That package seems okay! No memory problem! But it is PHP 4.3.6-dev,
not PHP 4.3.5 release. Or is it the same? Is there a newer (and better)
package for 4.3.5 (release) like this one (without memory lack)?
But last but not least big thanx!
------------------------------------------------------------------------
[2004-04-01 14:20:42] iliaa@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php4-STABLE-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-STABLE-latest.zip
------------------------------------------------------------------------
[2004-04-01 14:16:07] kvo at apachefriends dot org
Description:
------------
An apache 2.0.49 shutdown error by hand (after start manualy).
Beetween, execute some php files over the server.
Error: WinNT cannot clean the memory stack ... File: php4ts.dll. I
replace the php4ts.dll with an older version (4.3.4) and all is okay.
But then i have an older php ... Oh, and i see a dog by phpinfo()!!???
Yes, 1th april!!
You can provocate this problem with apache as servive:
net stop apache2
net start apache2
[Execute php files via lovalhost]
net stop apache2
System: XP Professional with 512 RAM and Athlon XP 1800 ++.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=27827&edit=1