#27988 [Opn->Bgs]: Linkage Error
| From: | sniper@php.net | Date: | Wed, 14 Apr 2004 14:13:26 +0000 |
| Subject: | #27988 [Opn->Bgs]: Linkage Error | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-58120@lists.php.net to get a copy of this message | ||
ID: 27988
Updated by: sniper@php.net
Reported By: djpenton at cs dot mu dot oz dot au
-Status: Open
+Status: Bogus
Bug Type: Apache2 related
Operating System: Solaris 2.9
PHP Version: 5.0.0RC1
New Comment:
The path to the xml lib is missing from your LD_LIBRARY_PATH or you
have old libxml headers/libs somewhere in it.
You can also try using this:
--with-libxml-dir=/home/projects/lt/projects/acla-db/server/libxml2-2.6.8
Previous Comments:
------------------------------------------------------------------------
[2004-04-14 05:42:45] djpenton at cs dot mu dot oz dot au
Forgot the configure lines:
(php)
./configure
--with-apxs2=/home/projects/lt/projects/acla-db/server/httpd/bin/apxs
--with-mysql --prefix=/home/projects/lt/projects/acla-db/server/php
--with-zlib
--with-config-file-path=/home/projects/lt/projects/acla-db/server/httpd/lib
(apache)
./configure --without-innodb
--prefix=/home//projects/lt/projects/acla-db/server/httpd --enable-so
--enable-rewrite
(libxml2)
./configure
--prefix=/home/projects/lt/projects/acla-db/server/libxml2-2.6.8
------------------------------------------------------------------------
[2004-04-14 05:38:57] djpenton at cs dot mu dot oz dot au
Description:
------------
Php runs fine at the command line.
But when I try and load the http daemon I get the following error:
Cannot load
/home/projects/lt/projects/acla-db/server/httpd/modules/libphp5.so into
server: ld.so.1:
/home//projects/lt/projects/acla-db/server/httpd/bin/httpd: fatal:
relocation error: file
/home/projects/lt/projects/acla-db/server/httpd/modules/libphp5.so:
symbol xmlNewValidCtxt: referenced symbol not found
I don't get the problem with php 4.3.4. I have a standard httpd.conf
file. The two php versions are in separate locations. The locations are
correctly specified.
I had to install libxml2-2.6.8 from source. It passed all make tests
and neither it nor php nor apache had any compilation/make/make install
errors.
Not sure what to do next. Tried new separate installation of
apache/php. Might try older version of libxml.
Hope you can help,
Cheers,
Dave.
Reproduce code:
---------------
non-code
Expected result:
----------------
non-code
Actual result:
--------------
non-code
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=27988&edit=1