#24138 [Com]: $PATH_INFO no longer works on IIS 5
| From: | mythz at hotmail dot com | Date: | Wed, 21 Apr 2004 13:33:02 +0000 |
| Subject: | #24138 [Com]: $PATH_INFO no longer works on IIS 5 | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-58518@lists.php.net to get a copy of this message | ||
ID: 24138
Comment by: mythz at hotmail dot com
Reported By: griffina at rappcollins dot com
Status: Bogus
Bug Type: *URL Functions
Operating System: IIS/WINNT
PHP Version: 4.3.2
New Comment:
Can someone please fix this for php cgi/sapi on iis/windows.
I find this painful as this was working previously with an older
version of php and it has yet to be fixed in the latest versions of
php.
When trying to view http://localhost/myapp/login.php/ADMIN
PHP CGI on IIS:
returns a 404 error not found page
PHP isapi on IIS:
Warning: Unknown(c:\inetpub\wwwroot\ADMIN): failed to open stream: No
such file or directory in Unknown on line 0
Warning: (null)(): Failed opening 'c:\inetpub\wwwroot\ADMIN' for
inclusion
(include_path='.;c:\php\includes;c:\Inetpub\wwwroot\contentwriter\base\PEAR')
in Unknown on line 0
Its about time this bug gets and stays fixed as it is almost impossible
to support a cross-platform application written in php that works in
more than 1 php version.
Previous Comments:
------------------------------------------------------------------------
[2003-06-11 17:12:35] griffina at rappcollins dot com
I did search the database - nothing similiar to the same problem
(btween versions 4.3.1 and 4.3.2). Additionally, I downloaded the most
recent snap to see if this issue had been caught, but it had not.
Please advise if I am missing something.
------------------------------------------------------------------------
[2003-06-11 17:08:14] sniper@php.net
Try search the bug database BEFORE you report anything..
------------------------------------------------------------------------
[2003-06-11 17:01:48] griffina at rappcollins dot com
Description:
------------
I was running 4.3.1, and $PATH_INFO resolved fine. I ungraded to 4.3.2
and it no longer seems to work.
Reproduce code:
---------------
echo(getenv("PATH_INFO"));
Name the above file test.php
Type into the browser http://test.php/key/variable
Expected result:
----------------
it should print /key/variable
Actual result:
--------------
page not found.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=24138&edit=1