#27810 [Com]: Apache-2.0.49 crashes on graceful/restart
| From: | jorton at redhat dot com | Date: | Fri, 23 Apr 2004 11:16:49 +0000 |
| Subject: | #27810 [Com]: Apache-2.0.49 crashes on graceful/restart | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-58636@lists.php.net to get a copy of this message | ||
ID: 27810
Comment by: jorton at redhat dot com
Reported By: renato at galle dot com dot br
Status: Open
Bug Type: Apache2 related
Operating System: FreeBSD-5.2.1-RELEASE-p4
PHP Version: 4.3.5
New Comment:
php dot 5 dot bluemonster at xoxy dot net, can you get a core dump and
backtrace? If it's only triggered by use of mod_ssl, it sounds like a
different bug.
Previous Comments:
------------------------------------------------------------------------
[2004-04-22 22:40:58] php dot 5 dot bluemonster at xoxy dot net
I continue to have a problem on graceful restart when
using the alternative patch. No error is logged but
Apache stops responding after `apachectl graceful' or
sending HUP. It does seem to work with a normal stop/
startssl. I'm on FreeBSD 5.2.1, whereas the others,
for whom it's working, are on Linux.
I've reverted to a backup of 4.3.4 and am looking into
FastCGI as an alternative.
------------------------------------------------------------------------
[2004-04-22 16:33:37] sugihara at gix dot or dot jp
OS : VineLinux2.6r4(kernel2.4.22)
Apache: 2.0.49
PHP : 4.3.6
I tried jorton's "alternative patch" too.
With or without SSL Apache behave properly when it catch 'HUP' or
'USR1' signal.
------------------------------------------------------------------------
[2004-04-22 01:22:24] danu at drydog dot com
I tried jorton's "alternative patch" with PHP 4.3.6 and Apache 2.0.49
(with SSL) on an otherwise standard RedHat 9 on Intel. I can confirm it
works (that is, I can restart Apache) on 2 different systems.
YEAH!!!!!!
Previous to patching, it did not work (that is, Apache errored out with
these messages in the Apache error log:
[Wed Mar 31 17:14:43 2004] [notice] SIGHUP received. Attempting to
restart
[Wed Mar 31 17:14:43 2004] [notice] seg fault or similar nasty error
detected in the parent process
[Wed Mar 31 17:14:48 2004] [warn] pid file /var/run/httpd.pid
overwritten -- Unclean shutdown of previous Apache run?
------------------------------------------------------------------------
[2004-04-22 00:26:07] jorton at redhat dot com
Can you try this alternative patch:
http://www.apache.org/~jorton/php-4.3.6-pcrealloc.patch
------------------------------------------------------------------------
[2004-04-21 15:58:16] php dot 5 dot bluemonster at xoxy dot net
I continue to have problems with this, on FreeBSD 5.2.1
using ale's patched port for 4.3.6 and apache 2.0.49.
apache seems to survive a graceful restart when I start
it without SSL, but if I stop apache it leaves behind a
bunch of httpd processes that I have to kill.
If I start apache with SSL then it does not survive the
graceful restart.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/27810
--
Edit this bug report at http://bugs.php.net/?id=27810&edit=1