#11058 [Com]: php_network_getaddresses: getaddrinfo failed
| From: | cosas at minovela dot com | Date: | Wed, 12 May 2004 22:32:51 +0000 |
| Subject: | #11058 [Com]: php_network_getaddresses: getaddrinfo failed | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-59558@lists.php.net to get a copy of this message | ||
ID: 11058
Comment by: cosas at minovela dot com
Reported By: pat at mail dot rit dot edu
Status: Bogus
Bug Type: Network related
Operating System: OpenBSD 2.6
PHP Version: 4.0.6
New Comment:
so nobody give us a solution?
i can't upgrade to latest version if i want to use fsockopen :(
Previous Comments:
------------------------------------------------------------------------
[2004-05-04 14:35:56] jeppe at bundsgaard dot net
I guess it is connected to the server - the problem occurs on some, but
not all the servers running php4.3 that I am using. Anyway it would be
nice with a solution that solves the problem independent of the servers
- or that tells exactly what is to be done with the server (I know,
this is not the place for such a request - but I don't know where to
turn to).
------------------------------------------------------------------------
[2004-02-12 21:15:45] cosas at minovela dot com
hello,
my php is PHP Version 4.3.4
i've exatctly the same problem. my server isn't conected by dialup, and
i got ever the message
"php_network_getaddresses: getaddrinfo failed"
when i use this line:
fsockopen ("dummy_ip", 25, &$errno, &$errstr, 10)
it didn't occurs with older versions of php.
this IS NOT a server problem, is a problem of PHP, you only need tho
make a search at google
http://www.google.es/search?hl=es&ie=UTF-8&oe=UTF-8&q=php+php_network_getaddresses%3A+getaddrinfo+failed&meta=
target "php_network_getaddresses: getaddrinfo failed"
and see results, a lot of people get the same errors.
i hope you found a solution for this :)
------------------------------------------------------------------------
[2003-06-04 10:08:18] fcartegnie dot at dot free dot dot dot fr at null
dot null
Okay. I identified the problem.
When apache starts, php or apache gets dns servers entry
from /etc/resolv.conf
You're using a dialup connection and when logging in, your dns servers
have been added at this later moment.
So there's a problem with apache or php to get informed that the
content of resolv.conf has been updated.
Confirmed for PHP 4.3.1/apache_1.3.27 so.
Temporary solution is just to reload apache doing a apachectl
stop/start
------------------------------------------------------------------------
[2002-04-03 16:27:07] g dot almasi at gigcity dot com
Well you can tell I had nothing to do today but beat my head against a
wall. But I found a solution!
I added my target site to /etc/hosts and restarted apache, and now I
can include a page in that target site from a different site.
It's Miller Time! <psht, glug glug glug>
------------------------------------------------------------------------
[2002-04-03 16:20:32] wez@php.net
And that is the cause of the problem (and the reason that
this report is set to bogus).
You need to tell your SuSE box how to resolve the addresses; the SuSE
yast tool should let you set the nameserver in it's network
configuration.
I can't help you any further here, and this is not the place to discuss
this further. I'd suggest looking at the SuSE support database for
this: it's bound to be a FAQ.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/11058
--
Edit this bug report at http://bugs.php.net/?id=11058&edit=1