#7641 [Com]: cgi binary with "enable-discard-path" fails with empty doc_root value

From: Date: Fri, 11 Jun 2004 04:44:09 +0000
Subject: #7641 [Com]: cgi binary with "enable-discard-path" fails with empty doc_root value
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-60764@lists.php.net to get a copy of this message
ID: 7641 Comment by: paul at boxedart dot com Reported By: ugb-listen at gmx dot de Status: Closed Bug Type: *Web Server problem Operating System: Linux 2.2.16 i686 PHP Version: 4.0 Latest CVS (04/11/2000) New Comment: Setting doc_root in php gives the message "No input file specified." I'll post back in a few with what happens with i compile without the discard option. Previous Comments: ------------------------------------------------------------------------ [2004-06-11 06:39:33] paul at boxedart dot com problem occurs with FC1 php SRPM , changed spec added --enable-fastcgi and got this error. Can reproduce easily. SRPM from Fedora is php-4.3.6-1.3.src.rpm and it does include the discard path option in the spec file. I will try setting php.ini option and also recompiling without --enable-discard-path ------------------------------------------------------------------------ [2004-05-14 22:18:32] ftrudeau at zesolution dot com Problem still occuring with PHP 4.3.5, might as well reopen this bug case. ------------------------------------------------------------------------ [2002-01-10 02:06:00] lobbin@php.net No feedback. Closing. ------------------------------------------------------------------------ [2001-12-20 09:48:50] lobbin@php.net Any luck with the testing? PHP 4.1.0 might be a wise choice as well. R. ------------------------------------------------------------------------ [2001-08-20 12:28:41] ugb-listen at gmx dot de Unfortunately, I am currently not able to test it due to time limitation. Please do not close the bug report yet, I might have time to test ist in the next couple of weeks (this report is 8 months old anyway). ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/7641 -- Edit this bug report at http://bugs.php.net/?id=7641&edit=1

« previous php.bugs (#60764) next »