#28825 [Com]: session_start(): Failed to initialize storage module
| From: | arnor at netvistun dot is | Date: | Fri, 09 Jul 2004 12:57:03 +0000 |
| Subject: | #28825 [Com]: session_start(): Failed to initialize storage module | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-61957@lists.php.net to get a copy of this message | ||
ID: 28825
Comment by: arnor at netvistun dot is
Reported By: searchadm at goschorn dot de
Status: Open
Bug Type: Session related
Operating System: Suse Linux 8.2
PHP Version: 4.3.7
New Comment:
I've tried hundreds of things for many days, but I'm beginning to
suspect that this is not a fault in php but a proplem caused by the
control panel I'm using: cPanel/WHM. I blamed them at first but they
looked at the problem with root access to our server for days, but said
at the end that this is a problem with php... everybody points fingers.
I even contacted a problem solving company, but they simply said that
at this point they "do not support fedora" environments (even though
they support most other distributions)...
Btw... I'm willing to pay money somebody can fix this.
Previous Comments:
------------------------------------------------------------------------
[2004-07-09 14:32:40] searchadm at goschorn dot de
the problem is not a diskspace problem and not a file count problem.
------------------------------------------------------------------------
[2004-07-09 13:30:19] arnor at netvistun dot is
One more thing.
I've tried using a event program to trigger an event on each
modification in the session save directory (in my case /tmp2).
The program runs chmod, chgrp, chown to give anybody rights to do
anything (I know that's not wise, but I'm desperate) and a script that
deletes all files that are 0 bytes in size (i noticed there were a lot
of those).
This did not help at all!
------------------------------------------------------------------------
[2004-07-08 19:30:42] arnor at netvistun dot is
We (me and the company I work for) have also been having this problem
for the last month. This error appears randomly. We made a script to a
cronjob which is exicuted every minute. In a log of that script it
looks like this error appears in about 6% of ALL request.
You can view this log at: http://www.netvistun.is/session_log/log.php
the script that can cause this error (and is requested each minute) is
at http://www.netvistun.is/session_log/index.php
php_info is at http://www.netvistun.is/session_log/info.php
The only thing you need to cause this error is:
<?php session_start() ?>
and that's it.
We have made owner/permission changes to the /tmp folder, we have tried
clearing the temp directory, we have tried changing the session save
directory to another dir. There is lots of space in the directory.
We've tried restarting apache every 24 hours, we have done all of the
workarounds which you see all over these bug tracks.
This bug has been appearing for a long time in the bugtrack (saw one
from php 4.1.x), and is always closed with some "workaround".
We've experienced this problem ever since php 4.3.1, up to 4.3.7.
We are currently running :
php 4.3.7
Apache 1.3.31
Linux dist.: Fedora
Control panel: WHM (cPanel)
php config:
'./configure' '--with-apxs=/usr/local/apache/bin/apxs' '--with-xml'
'--enable-bcmath' '--enable-calendar' '--with-curl'
'--enable-exif'
'--enable-ftp' '--with-gd' '--with-jpeg-dir=/usr/local'
'--with-png-dir=/usr' '--with-xpm-dir=/usr/X11R6' '--with-imap'
'--with-imap-ssl' '--with-kerberos' '--enable-mbstring'
'--enable-mbstr-enc-trans' '--enable-mbregex'
'--with-ming=../ming-0.2a' '--enable-magic-quotes' '--with-mysql'
'--with-openssl' '--enable-discard-path' '--with-pear'
'--enable-xslt'
'--with-xslt-sablot' '--enable-sockets' '--enable-track-vars'
'--enable-versioning' '--with-xmlrpc' '--with-zlib'
Session Support enabled
Registered save handlers files user
Directive Local Value Master Value
session.auto_start Off Off
session.bug_compat_42 On On
session.bug_compat_warn On On
session.cache_expire 180 180
session.cache_limiter nocache nocache
session.cookie_domain no value no value
session.cookie_lifetime 0 0
session.cookie_path / /
session.cookie_secure Off Off
session.entropy_file no value no value
session.entropy_length 0 0
session.gc_divisor 100 100
session.gc_maxlifetime 1440 1440
session.gc_probability 1 1
session.name PHPSESSID PHPSESSID
session.referer_check no value no value
session.save_handler files files
session.save_path /tmp2 /tmp2
session.serialize_handler php php
session.use_cookies On On
session.use_only_cookies Off Off
session.use_trans_sid On On
Any other info I can give, I will give gladly (except root passwords of
course :D)
I Hope I help.
------------------------------------------------------------------------
[2004-07-07 01:00:05] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
------------------------------------------------------------------------
[2004-06-29 18:07:35] iliaa@php.net
When this error happens see if the directory where the
sessions are being written to has enough space and if the
system is not running out of file handles.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/28825
--
Edit this bug report at http://bugs.php.net/?id=28825&edit=1