#29157 [Opn->Bgs]: 'make install' of Apache 2 SAPI fails to prepend module path with leading slash
| From: | derick@php.net | Date: | Wed, 14 Jul 2004 16:18:17 +0000 |
| Subject: | #29157 [Opn->Bgs]: 'make install' of Apache 2 SAPI fails to prepend module path with leading slash | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-62265@lists.php.net to get a copy of this message | ||
ID: 29157
Updated by: derick@php.net
Reported By: bjorn dot wiberg at home dot se
-Status: Open
+Status: Bogus
Bug Type: Apache2 related
Operating System: Debian GNU/Linux 3.0.0r2 (mixed)
PHP Version: 5.0.0
New Comment:
This is an apxs2 problem, not ours.
Previous Comments:
------------------------------------------------------------------------
[2004-07-14 18:09:51] bjorn dot wiberg at home dot se
Description:
------------
When running 'make install', the directive added to
/etc/apache2/apache2.conf misses a leading slash (/) to the PHP 5
module.
I do not know if this is due to an error in apxs2 or in the way PHP 5's
'make install' calls it, but it has been around for quite some time
now.
Furthermore, at least one other LoadModule directive must be present in
/etc/apache2/apache2.conf before running 'make install', or apxs2 will
fail to insert the line (it doesn't know where to put it), and the
'make install' fails. For this purpose I use:
# Commented-out dummy LoadModule directive to give apxs2 a hint
# about where to place new LoadModule directives (e.g. PHP)
#
# LoadModule dummy_module /usr/lib/apache2/modules/mod_dummy.so
That way, the PHP 5 LoadModule directive gets inserted right after the
(commented-out) dummy line.
Reproduce code:
---------------
1. Configure PHP 5. I use the following directives:
./configure --enable-bcmath --enable-calendar --enable-dba --enable-dio
--enable-embedded-mysqli --enable-exif --enable-ftp
--enable-gd-native-ttf --enable-gd-jis-conv --enable-mbstring
--enable-memory-limit --enable-pcntl --enable-shmop --enable-soap
--enable-sockets --enable-sysvmsg --enable-sysvsem --enable-sysvshm
--enable-wddx --enable-yp --enable-zend-multibyte
--with-apxs2=/usr/bin/apxs2 --with-bcmath --with-bz2 --with-curl
--with-db4 --with-freetype-dir=/usr/lib --with-gd --with-gettext
--with-gmp --with-iconv --with-inifile --with-jpeg-dir=/usr/lib
--with-ldap --with-libxml-dir=/usr/lib --with-mime-magic --with-mysql
--with-mysql-sock --with-ncurses --with-openssl --with-png-dir=/usr/lib
--with-pspell --with-snmp --with-tiff-dir=/usr/lib --with-ttf
--with-xmlrpc --with-xpm-dir=/usr/lib --with-xsl --with-zlib
--with-zlib-dir=/usr/lib
2. Compile PHP 5 with 'make'.
3. Run 'make install'.
4. View /etc/apache2/apache2.conf.
Expected result:
----------------
LoadModule php5_module /usr/lib/apache2/modules/libphp5.so
Actual result:
--------------
LoadModule php5_module usr/lib/apache2/modules/libphp5.so
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=29157&edit=1