#10619 [Com]: Apache is not able to load the php module
| From: | buzzcarter at hotmail dot com | Date: | Sat, 17 Jul 2004 16:14:53 +0000 |
| Subject: | #10619 [Com]: Apache is not able to load the php module | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-62528@lists.php.net to get a copy of this message | ||
ID: 10619
Comment by: buzzcarter at hotmail dot com
Reported By: sonnysavage at yahoo dot com
Status: Bogus
Bug Type: Apache related
Operating System: Windows NT 4.0 Build 1381
PHP Version: 4.0.5
New Comment:
Thanks... i just re-installed apache/php on WinXP and got the error
described. Thanks to this post I discovered that an old copy of
php4ts.dll was in my C:\WINDOWS\SYSTEM32
Once i replaced with the new version of php4ts.dll all works fine.
Previous Comments:
------------------------------------------------------------------------
[2001-05-03 11:44:09] sonnysavage at yahoo dot com
I have isolated the cause of the problem(at least my problem).
In my case, I commented out the following line in php.ini
extension=php_mssql70.dll
Then the Apache crash does not happpen.
Hope this helps
------------------------------------------------------------------------
[2001-05-03 11:20:20] cynic@php.net
you don't need to have php4ts.dll in windows/system/, just leave it in
the directory where apache.exe is.
Zend Optimizer is a third party product, report the errors to Zend.
------------------------------------------------------------------------
[2001-05-03 11:11:12] sonnysavage at yahoo dot com
Here is a link to a similar thread on phpbuilder.com:
http://www.phpbuilder.com/forum/read.php3?num=3&id=104846&loc=0&thread=104846
------------------------------------------------------------------------
[2001-05-03 11:09:26] sonnysavage at yahoo dot com
I have solved the problem. I didn't copy the new php4ts.dll to my sys
directory.
Another problem however is that the Zend optimizer doesn't work. I
have version 1.1.0 and it gives me a pile of errors. I commented the
zend lines out of my php.ini, and the php apache module loads fine now.
------------------------------------------------------------------------
[2001-05-03 10:06:03] sonnysavage at yahoo dot com
I tried again, and here are the steps that I took:
1) I uninstalled and removed all files for both PHP and Apache.
2) I unzipped PHP 4.0.5, copied the "php.ini-dist" to "php.ini" in my
WinNT folder, Rebooted, Installed Apache 1.3.19, added this line to my
httpd.conf file "LoadModule php4_module c:/php/sapi/php4apache.dll" (as
well as other configurations).
3) When starting Apache, I get the exact same error as before.
4) I replaced the 4.0.5 version of the php4apache.dll with the 4.0.4pl1
version, and Apache started without a hitch.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/10619
--
Edit this bug report at http://bugs.php.net/?id=10619&edit=1