#29375 [Opn->Fbk]: make test - Error 139
ID: 29375
Updated by: helly@php.net
Reported By: simone at ivg dot it
-Status: Open
+Status: Feedback
Bug Type: DBM/DBA related
Operating System: Linux
PHP Version: 4.3.8
New Comment:
What does that mean? You can build and execute the tests and a few fail
and then get the error? That would be normal behavior. Or can't you do
the tests (unable to run php at all)? And if you drop the line
mentioned it works? In that case what version of db4 do you use exactly
(4.2.x)?
Previous Comments:
------------------------------------------------------------------------
[2004-08-02 11:50:35] simone at ivg dot it
Any ideas?
------------------------------------------------------------------------
[2004-07-25 16:05:29] simone at ivg dot it
Description:
------------
when I compile php-4.3.8 , nothing wrong.
But when I try to exec tests ( make test )
it returns :
make: [test] Error 139 (ignored)
My configure parameters are:
./configure \
--with-apxs=/usr/local/apache/bin/apxs \
--enable-safe-mode \
--enable-magic-quotes \
--with-openssl=/usr/local/ssl \
--enable-bcmath \
--enable-calendar \
--with-curl=/usr/local/src/curl-7.10.5 \
--enable-ftp \
--with-gd=/usr/local/src/gd-2.0.21 \
--with-jpeg-dir=/usr/local/src/jpeg-6b \
--with-png-dir=/usr/local/src/libpng-1.2.5 \
--with-freetype-dir=/usr/local/src/freetype-2.1.5 \
--with-gettext=/usr/local/src/gettext-0.13 \
--with-imap=/usr/local/src/imap-2002e \
--with-imap-ssl=/usr/local/ssl \
--enable-mbstring \
--enable-mbregex \
--with-mcrypt=/usr/local/src/libmcrypt-2.5.7 \
--with-mysql=/usr/local/mysql \
--with-jpeg-dir=/usr/local/src/jpeg-6b \
--with-png-dir=/usr/local/src/libpng-1.2.5 \
--with-tiff-dir=/usr/local/src/tiff-v3.5.7 \
--with-mm=/usr/local/src/mm-1.3.0 \
--enable-sockets \
--enable-sysvsem \
--enable-sysvshm \
--with-zip=/usr/local/src/zziplib-0.10.27 \
--enable-inline-optimization \
--enable-memory-limit \
--enable-zend-multibyte \
--with-tsrm-pthreads \
--with-zlib \
--with-zlib-dir=/usr/local/src/zlib-1.2.1 \
--enable-sigchild \
--enable-dbase \
--enable-dio \
--enable-exif \
--enable-ftp \
--enable-sysvmsg \
--with-pear \
--enable-dba \
--with-db4=/usr/local/BerkeleyDB.4.2
I suspect there are problems with BerkeleyDB ( if I remove last line,
all seems ok ) but I cannot be more specific.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=29375&edit=1
Thread (7 messages)