#29224 [Com]: DB Error: extension not found
| From: | dinojazz at hotmail dot com | Date: | Mon, 02 Aug 2004 12:02:49 +0000 |
| Subject: | #29224 [Com]: DB Error: extension not found | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-63932@lists.php.net to get a copy of this message | ||
ID: 29224
Comment by: dinojazz at hotmail dot com
Reported By: marcschroeder at hotmail dot com
Status: Bogus
Bug Type: *Configuration Issues
Operating System: Microsoft Windows XP
PHP Version: 5.0.0
New Comment:
I am having the issues as well. My php_mysql.dll is located in c:\php
and php.ini knows this. I've moved libmysql.dll to c:\windows\system32
as well. On top of this all, the extension=php_mysql.dll in php.ini has
been uncommented.
Yet, I get errors when I try to have mysql/php things loaded in my
webpage. It comes up with 'Unable to load dynamic library
'c:\php\php_mysql.dll\' - The specified procedure could not be found'.
I've tried the suggestions like php_mysql.dll to c:\windows\system32
and all the stuff. Even moved libmysql.dll to various places, but
nothing worked. I am kind of stumped here, looks like there's some
heavy bug in there.
Previous Comments:
------------------------------------------------------------------------
[2004-08-02 11:24:40] edink@php.net
Either add c:\php to your system path, or copy all dlls from that
folder to system32.
------------------------------------------------------------------------
[2004-08-02 00:36:20] tipsen at imada dot sdu dot dk
I solved the problem by copying the file "libmysql.dll" from the php5
root to the win/system32 library - I have no idea why this works but
stumpled upon the suggestion on a website!
Regards, Tommy Ipsen
------------------------------------------------------------------------
[2004-07-30 11:29:25] patrick dot allaert at belgacom dot be
After the installation on WindowsXP/IIS of PHP 5.0.0 (stable) in
c:\PHP\ and configuring the php.ini with:
extension_dir = "c:\PHP\ext"
I receive the following message:
"PHP Startup: Unable to load dynamic library
'c:\PHP\ext\php_EXTENSIONNAME.dll' - The specified module could not be
found"
for all extensions except:
php_bz2.dll
php_cpdf.dll
php_curl.dll
php_dba.dll
php_dbase.dll
php_dbx.dll
php_filepro.dll
php_gd2.dll
php_gettext.dll
php_imap.dll
php_ldap.dll
php_mbstring.dll
php_mime_magic.dll
php_ming.dll
php_mysqli.dll
php_openssl.dll
php_oracle.dll
php_pgsql.dll
php_shmop.dll
php_snmp.dll
php_sockets.dll
php_tidy.dll
php_xmlrpc.dll
php_xsl.dll
All the other extensions result in the error above (of course, some of
them cannot be loaded because of 3rd-parties dll missing like with oci8
but what about php_mysql.dll, php_mysqli.dll, ...)
------------------------------------------------------------------------
[2004-07-17 12:33:40] marcschroeder at hotmail dot com
Remark (3): commenting in the line "extension=php_mysql.dll"
in php.ini does not help either
------------------------------------------------------------------------
[2004-07-17 12:19:13] marcschroeder at hotmail dot com
Description:
------------
I had installed the windows binaries php-4.3.6-Win32.zip, and the PEAR
DB package worked fine. After installing the binaries
php-5.0.0-Win32.zip, I got the error "DB Error: extension not found".
Remarks:
(1) Copying the file php_mysql.dll into the directory
C:\WINDOWS\systm32 does not help.
(2) Even if it did, there would be a bug.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=29224&edit=1