#29227 [Opn]: mod_ssl + php5 will crash!
| From: | herps at raqtweak dot com | Date: | Sun, 08 Aug 2004 01:37:59 +0000 |
| Subject: | #29227 [Opn]: mod_ssl + php5 will crash! | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-64245@lists.php.net to get a copy of this message | ||
ID: 29227
User updated by: herps at raqtweak dot com
Reported By: herps at raqtweak dot com
Status: Open
Bug Type: Apache related
Operating System: RedHat 7.x
PHP Version: 5.0.0
New Comment:
Took me hours of debugging, but issue resolved. I was right, it is a
conflict between PHP and mod_ssl.
Previous Comments:
------------------------------------------------------------------------
[2004-08-08 01:46:18] herps at raqtweak dot com
Well, I posted as much information as I can, and what I get from
http://bugs.php.net/how-to-report.php I did just
fine...
Can someone help?!!!
------------------------------------------------------------------------
[2004-07-18 16:54:54] herps at raqtweak dot com
Not sure what you need...
I compile PHP 5.0.0, REGARDLESS OF THE COMPILE OPTIONS I USE, the
following happens.
Option #1
I restart Apache,
in the httpd.conf
LoadModule php5_module modules/php-5.0.0/libphp5.so
LoadModule ssl_module modules/libssl.so
Check this,
[root conf]# /etc/rc.d/init.d/httpd restart ; ps ax | grep httpd
Shutting down Web Service: httpd ok
/etc/rc.d/init.d/httpd: line 3: 17200 Killed
$LCD_SWRITE "$LINE1" "$LINE2" >/dev/null 2>&1
Setting up Web Service: httpd
800 ? S 0:00 /usr/sbin/httpd.admsrv -f
/etc/admserv/conf/httpd.con
10940 ? S 0:00 /usr/sbin/httpd.admsrv -f
/etc/admserv/conf/httpd.con
17234 pts/0 R 0:00 /usr/sbin/httpd -DHAVE_I18N -DHAVE_CCE
-DHAVE_INTERBA
Then, 5 seconds later, I do another "ps ax | grep httpd"
No result. httpd crashed.
Now, I comment out
# LoadModule ssl_module modules/libssl.so
restart apache, and everything runs fine, forever....
------------------------------------------------------------------------
[2004-07-17 20:39:51] wez@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php
If you can provide more information, feel free to add it
to this bug and change the status back to "Open".
Thank you for your interest in PHP.
------------------------------------------------------------------------
[2004-07-17 17:48:54] herps at raqtweak dot com
Description:
------------
Trying to upgrade PHP 4.3.7 to PHP 5.0.0.
This machine is running Apache 1.3.29 with mod_ssl/2.8.16
OpenSSL/0.9.6m.
Now, PHP5 will work fine, but as soon as I activate the mod_ssl module,
Apache crashes immediately after I start it...
When I disable mod_ssl, it works fine.
I have tried numerous things, different kernels, different openssl
versions (0.9.6, 0.9.6m, 0.9.7d), recompiled Apache, nothing! Same
problem over and over...
The backtrace I get:
Reading symbols from /lib/libpthread.so.0...done.
warning: Unable to set global thread event mask: generic error
[New Thread 1024 (LWP 9814)]
Error while reading shared library symbols:
Cannot enable thread event reporting for Thread 1024 (LWP 9814):
generic error
Reading symbols from /lib/libnss_db.so.2...done.
Loaded symbols for /lib/libnss_db.so.2
Reading symbols from
/usr/lib/perl5/5.6.0/i386-linux/auto/Data/Dumper/Dumper.so...done.
Loaded symbols for
/usr/lib/perl5/5.6.0/i386-linux/auto/Data/Dumper/Dumper.so
Reading symbols from
/usr/lib/perl5/5.6.0/i386-linux/auto/IO/IO.so...done.
Loaded symbols for /usr/lib/perl5/5.6.0/i386-linux/auto/IO/IO.so
Reading symbols from
/usr/lib/perl5/5.6.0/i386-linux/auto/Fcntl/Fcntl.so...done.
Loaded symbols for /usr/lib/perl5/5.6.0/i386-linux/auto/Fcntl/Fcntl.so
Reading symbols from
/usr/lib/perl5/5.6.0/i386-linux/auto/Socket/Socket.so...done.
Loaded symbols for
/usr/lib/perl5/5.6.0/i386-linux/auto/Socket/Socket.so
Reading symbols from /usr/lib/gconv/ISO8859-1.so...done.
Loaded symbols for /usr/lib/gconv/ISO8859-1.so
#0 0x4000b9f7 in _dl_signal_error () at eval.c:88
88 eval.c: No such file or directory.
Expected result:
----------------
Should run just fine, since 4.3.7 with the same config runs perfectly
fine!
Actual result:
--------------
You see an httpd process spawn, then it crashes immediately...
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=29227&edit=1