#29608 [Com]: OCi reports OCIStmtExecute: ORA-24324: service handle not initialized
| From: | izhekov at ppartner dot com | Date: | Wed, 11 Aug 2004 14:34:50 +0000 |
| Subject: | #29608 [Com]: OCi reports OCIStmtExecute: ORA-24324: service handle not initialized | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-64427@lists.php.net to get a copy of this message | ||
ID: 29608
Comment by: izhekov at ppartner dot com
Reported By: tomek at matrox dot pl
Status: Feedback
Bug Type: OCI8 related
Operating System: W2k, Red Hat
PHP Version: 5.0.0
New Comment:
I have the same problem. If you search in google for this error, you'll
find some sites that have the same problem. I'm using Windows 2003
Server. I think this bug is fatal for many people. I think the OCI8
functions did not work at all in PHP 5.
Previous Comments:
------------------------------------------------------------------------
[2004-08-11 09:51:44] tony2001@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php
If you can provide more information, feel free to add it
to this bug and change the status back to "Open".
Thank you for your interest in PHP.
------------------------------------------------------------------------
[2004-08-11 09:44:33] tomek at matrox dot pl
Description:
------------
I wrote my site using PHP 4.3.8, W2k and Apache in both version 2 and
1.3.x. Everything was all right until the day when I decided to change
my php version (now I have 5.0.0)
Scripts which executes oracle queries sometimes works sometimes not.
I've notice 2 kinds of situations:
First : apache reports :
Warning: ociexecute() [function.ociexecute]: OCIStmtExecute: ORA-24324:
service handle not initialized in /usr/local/apache/htdocs/dupa1.php on
line 5
Second : apache child process is killed
I thought that problem is in OS. I tried to run my site on Red Hat with
apache 1.3.31 and php 5.0.0 and problem is still the same.
Changes in version of Oracle client also doesn't resolve the problem.
Reproduce code:
---------------
$query = 'SELECT * FROM opal_sesje';
$conn = ocilogon('xxx','xxx','xxx');
$stmt = OCIParse($conn, $query);
OCIexecute($stmt, OCI_DEFAULT);
$error = OCIError($stmt);
print_r($error);
Expected result:
----------------
just blank page
Actual result:
--------------
blank page or OCI warning or no result
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=29608&edit=1