#29624 [Com]: OCINlsEnvironmentVariableGet: referenced symbol not found
| From: | cjbj at hotmail dot com | Date: | Fri, 13 Aug 2004 00:17:54 +0000 |
| Subject: | #29624 [Com]: OCINlsEnvironmentVariableGet: referenced symbol not found | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-64513@lists.php.net to get a copy of this message | ||
ID: 29624
Comment by: cjbj at hotmail dot com
Reported By: dmarek1 at att dot net
Status: Open
Bug Type: OCI8 related
Operating System: Solaris 2.8
PHP Version: 5.0.0
New Comment:
I guess at runtime you're using the Oracle DB libraries that came with
iAS. These are probably older than the DB
environment you built with. Try building with the ORACLE_HOME
that you are running with. See
http://www.oracle.com/technology/products/ias/ohs/htdocs/php_ohs.htm
Previous Comments:
------------------------------------------------------------------------
[2004-08-12 03:01:09] dmarek1 at att dot net
Description:
------------
I am okay to build oci8 with PHP 5 and the make is okay but when I
start http server the error below occurs. I have iAS 10g for one home
with a 9.2 client on another. I build oci8 to 9.2 home and all other
to 10G iAS. Without oci8 all is good and the server runs and handles
PHP but with oci8 I can't go on.
Thanks for any help
/opt/oracle/product/TCLB/iAS/Apache/Apache/bin/apachectl start: execing
httpd
Syntax error on line 232 of
/opt/oracle/product/TCLB/iAS/Apache/Apache/conf/httpd.conf:
Cannot load
/opt/oracle/product/TCLB/iAS/Apache/Apache/libexec/libphp5.so into
server: ld.so.1: /opt/oracle/product/TCLB/i
AS/Apache/Apache/bin/httpd: fatal: relocation error: file
/opt/oracle/product/TCLB/iAS/Apache/Apache/libexec/libphp5.so: s
ymbol OCINlsEnvironmentVariableGet: referenced symbol not found
Reproduce code:
---------------
./configure --with-oci8=/opt/oracle/product/TCLB/9.2.C
--with-gd=/usr/local --with-jpeg-dir=/usr/local --with-png-dir=/usr
/local --with-zlib-dir=/usr/local --with-xpm-dir=/usr/local
--with-ttf=/usr/local --with-freetype-dir=/usr/local --enable-
gd-native-ttf --with-mysql=/usr/local/mysql
--with-apxs=/opt/oracle/product/TCLB/iAS/Apache/Apache/bin/apxs
--prefix=/opt/
oracle/product/TCLB/iAS
--with-config-file-path=/opt/oracle/product/TCLB/iAS/Apache/Apache/conf
Expected result:
----------------
Server starts and oci calls work!
Actual result:
--------------
Can't start server as error above shows.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=29624&edit=1