#29563 [Opn->Bgs]: locking problem
ID: 29563
Updated by: iliaa@php.net
Reported By: tom at bitworks dot de
-Status: Open
+Status: Bogus
Bug Type: Filesystem function related
Operating System: Debian Linux Woody & Apache/1.3.
PHP Version: 4.3.8
New Comment:
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to
report
a bug at http://bugs.php.net/how-to-report.php
If you want to lock files opened with dio_open() you need
to use dio_fcntl() to do so.
Previous Comments:
------------------------------------------------------------------------
[2004-08-07 20:28:27] tom at bitworks dot de
Description:
------------
There seam to be several logical implementation faults, concerning
flock() and dio_open()
1.) Opening a file by the first process with
$fh = dio_open($dateiname,O_RDWR + O_NONBLOCK ,0 );
does not trigger a failure opening the file twice by an other
process with the same method
You always get the ressource handle
2.) Opening the file twice, after having opened with upper
method, by the flock(..., LOCK_NB) function, causes a
waiststate for the flock() process.
That problem should be solved.
Remark:
Mandatory locking on LINUX only works, if You mount the volume with
option "mand" (-o mand) (missing Information in documentation)
Programs like vi nevertheless are able to override the "mandatory
locking" with the "x!" command. (only checked for a LINUX Debian Woody
system)
Expected result:
----------------
Triggering a failure (return false)
Actual result:
--------------
Waiting for locking
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=29563&edit=1
Thread (2 messages)