#10195 [Com]: https takes forever and a day to return when php is loaded in Apache
| From: | suyogtajne at yahoo dot com | Date: | Tue, 31 Aug 2004 10:30:13 +0000 |
| Subject: | #10195 [Com]: https takes forever and a day to return when php is loaded in Apache | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-65499@lists.php.net to get a copy of this message | ||
ID: 10195
Comment by: suyogtajne at yahoo dot com
Reported By: Clement dot Ong at shinetech dot com
Status: Closed
Bug Type: OpenSSL related
Operating System: Linux Red Hat 7.0
PHP Version: 4.0.2
New Comment:
Hi
i'm using mantis bug track 0.18 with apache server and mysql db , https
based.
i'm facing problems for uploaded files during reporting bugs...
.i'm not able to save them again from bug track page in their
format..(.doc,.zip etc)
it gives error as ...load.php file?%@#$$@
however it works fine for http based...
can anybody help??
Previous Comments:
------------------------------------------------------------------------
[2001-04-10 09:26:26] sniper@php.net
Closed. (that error can be get rid of by recompiling the Java extension
from the latest sources too)
--Jani
------------------------------------------------------------------------
[2001-04-09 22:30:42] Clement dot Ong at shinetech dot com
I've downloaded the latest tar :-
php4-200104091745
I no longer have the build error and https with PHP activated and curl
option specified now works. No more segmentation fault in the Apache
error_log file.
This is wonderful.
When starting up Apache I have the following error is this something to
worry about :-
PHP Warning: java: Unable to initialize module
Module compiled with debug=0, thread-safety=0 module API=20000809
PHP compiled with debug=0, thread-safety=0 module API=20001222
These options need to match
in Unknown on line 0
------------------------------------------------------------------------
[2001-04-09 04:05:15] Clement dot Ong at shinetech dot com
I tried building with the lastest build as suggested by you and the
build errored when it came to making sapi/cgi.
I compared the MakeFile in the sapi directory between php 4.02 and the
latest and they are different with the lastest one making reference to
CGI in several places.
Also 4.02 has a Makefile in sapi/cgi whereas the latest doesn't.
Also what version of curl are you using I'm using 7.7.1.
------------------------------------------------------------------------
[2001-04-06 11:30:28] sniper@php.net
Works for me just fine with latest RC of PHP 4.0.5 and latest CVS. And
I have the same versions of openssl and mod_ssl and I have Curl
enabled.
Please try the latest snapshot: http://snaps.php.net/
--Jani
------------------------------------------------------------------------
[2001-04-06 00:48:50] Clement dot Ong at shinetech dot com
Latest information. If I remove with-curl out from the configuration
and rebuild PHP the problem no longer appears.
I need the curl functionality to use https within the PHP script to
another secure web server.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/10195
--
Edit this bug report at http://bugs.php.net/?id=10195&edit=1