#29481 [Sus->Bgs]: HSE_REQ_MAP_URL_TO_PATH_EX failed
| From: | wez@php.net | Date: | Sun, 26 Sep 2004 02:05:59 +0000 |
| Subject: | #29481 [Sus->Bgs]: HSE_REQ_MAP_URL_TO_PATH_EX failed | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-66708@lists.php.net to get a copy of this message | ||
ID: 29481
Updated by: wez@php.net
Reported By: steffen at land10web dot com
-Status: Suspended
+Status: Bogus
Bug Type: URL related
Operating System: Windows XP + Sambar 6.1
PHP Version: 5CVS-2004-08-01 (dev)
New Comment:
User reports the problem resolved in latest Sambar release.
Marking this report as Bogus since the fix did not require changes in
PHP.
Previous Comments:
------------------------------------------------------------------------
[2004-09-26 03:58:38] steffen at land10web dot com
It is fixed by Tod in the Sambar 6.1 production release (see
http://www.sambarserver.info ).
PHP5 works great now with the Sambar Server.
Steffen
------------------------------------------------------------------------
[2004-09-10 14:02:25] wez@php.net
Tod: please try to have it work the same way as the MS implementation,
whatever that may be (still too busy to dig into it).
We'd welcome your patch!
------------------------------------------------------------------------
[2004-08-19 00:47:56] tod at sambar dot com
I'm happy to add support for this, but need to know what you are
expecting as a response. Since there is no URI element to translate,
do I just parrot back the ?x=y args from the Query string?
Many thanks!
Tod Sambar
------------------------------------------------------------------------
[2004-08-01 15:30:40] wez@php.net
?f=2 *is* a valid component of an URL.
It works on IIS, which is our only "officially supported" (and strongly
discouraged) ISAPI platform.
None of us have Sambar server or the time to test it.
Volunteers are welcome to submit a patch to fix it under Sambar, but it
must also not break IIS.
------------------------------------------------------------------------
[2004-08-01 14:42:29] steffen at land10web dot com
Description:
------------
Using Sambar 6.1 and I get in the ISAPI log:
With eg. the URL www.sambarserver.info/forum/viewforum.php?f=2 :
PHP5ISAPI.DLL: HSE_REQ_MAP_URL_TO_PATH_EX failed '?f=1'
All is working fine, only a lot failed enties in the log.
The response from Sambar Support is:
"I believe the URL_TO_PATH_EX is an issue on the part of PHP. They
should not be passing the ?f=2 in their lookup as that is not a valid
element of the URL"
Regards,
Steffen
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=29481&edit=1