#14351 [Com]: problems installing PHP as a DSO

From: Date: Sun, 10 Oct 2004 15:26:39 +0000
Subject: #14351 [Com]: problems installing PHP as a DSO
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-67363@lists.php.net to get a copy of this message
ID: 14351 Comment by: baja2 at yahoo dot co dot jp Reported By: ana at turbogenomics dot com Status: No Feedback Bug Type: Apache related Operating System: Linux RedHat-7.1 PHP Version: 4.0.6 New Comment: I solved this problem as follows. ln -s /usr/bin/perl /usr/local/bin/perl cd /opt/IBMHTTPServer/apachesrc tar -zvxf apache_tar.gz cp /opt/IBMHTTPServer/apachesrc/apache_1.3.20/os-inline.c /opt/IBMHTTPServer/include/ And, PHP-4.3.8 ./configure, ./make, ./make install Previous Comments: ------------------------------------------------------------------------ [2002-07-18 13:33:12] frank at oneonline dot it I'me the same problem with php 4.2.1 and Apache/1.3.6 on redhat 6.0 system. Please touch me on email address if reply. Francesco Amelio ------------------------------------------------------------------------ [2002-06-05 01:00:05] php-bugs at lists dot php dot net No feedback was provided for this bug for over a month, so it is being suspended automatically. If you are able to provide the information that was originally requested, please do so and change the status of the bug back to "Open". ------------------------------------------------------------------------ [2002-05-04 12:57:59] markonen@php.net This might have been fixed in a later version of of IBM HTTP Server. Have you / could you try it out? Thanks. ------------------------------------------------------------------------ [2001-12-05 12:08:37] ana at turbogenomics dot com I am running IBM_HTTP_SERVER/1.3.19 powered by Apache/1.3.20 and am having problems installing PHP as a loadable module of Apache. Method 1: I installed php-4.0.4pl1-9.i386.rpm and copied /usr/lib/apache/libphp4.so to the apache libexec directory. I then edited the httpd.conf file by adding the following: LoadModule php4_module libexec/libphp4.so AddType application/x-httpd-php .php4 .php3 .phtml .php When I try to restart the server, it cannot be started and I get the following message: API module structure 'php4_module' in file ... is garbled - perhaps this is not an Apache module DSO? Method 2: Compiling PHP source code and using apxs. the Apache does allow for DSO loading httpd -l lists http_core.c mod_so.c ./configure --prefix=/usr/local/php --with-apxs=/opt/IBMHTTPServer/bin/apxs make this ends with the following error: make[3]: Entering directory `/tmp/php-4.0.6/sapi/apache' /bin/sh /tmp/php-4.0.6/libtool --silent --mode=compile gcc -I. -I/tmp/php-4.0.6/sapi/apache -I/tmp/php-4.0.6/main -I/tmp/php-4.0.6 -I/opt/IBMHTTPServer/include -I/tmp/php-4.0.6/Zend -I/tmp/php-4.0.6/ext/mysql/libmysql -I/tmp/php-4.0.6/ext/xml/expat/xmltok -I/tmp/php-4.0.6/ext/xml/expat/xmlparse -I/tmp/php-4.0.6/TSRM -DLINUX=22 -DUSE_HSREGEX -DUSE_EXPAT -DSUPPORT_UTF8 -DXML_BYTE_ORDER=12 -g -O2 -c sapi_apache.c In file included from /opt/IBMHTTPServer/include/ap_config.h:114, from /opt/IBMHTTPServer/include/httpd.h:72, from sapi_apache.c:32: /opt/IBMHTTPServer/include/os.h:82:23: os-inline.c: No such file or directory make[3]: *** [sapi_apache.lo] Error 1 make[3]: Leaving directory `/tmp/php-4.0.6/sapi/apache' make[2]: *** [all-recursive] Error 1 make[2]: Leaving directory `/tmp/php-4.0.6/sapi/apache' make[1]: *** [all-recursive] Error 1 make[1]: Leaving directory `/tmp/php-4.0.6/sapi' make: *** [all-recursive] Error 1 Any help would be appreciated, Thanks! ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=14351&edit=1

« previous php.bugs (#67363) next »