#30563 [Opn]: Apache doesn't start with PHP. No errors reported.
ID: 30563
Updated by: jorton@php.net
Reported By: david at donpiso dot com
Status: Open
Bug Type: Apache2 related
Operating System: Linux 2.4.25
PHP Version: 4.3.9
New Comment:
Can you try with -X added to the flags passed to run in gdb, to try a
single-process startup.
Previous Comments:
------------------------------------------------------------------------
[2004-10-26 13:21:32] david at donpiso dot com
Description:
------------
Apache simply fails to start after loading all modules, it seems it
exits after loading, probably following initialization phase of the
modules. No error neither at console nor log files. This happens
since Apache 2.0.48 + PHP 4.3.4 in this machine, but I succeeded
to start Apache 2.0.49 + PHP 4.3.6 in a different machine. Now
tried Apache 2.0.52 + PHP 4.3.9 and still doesn't work.
This is PHP configure:
./configure --with-apxs2=/usr/local/apache-server2/bin/apxs
--enable-ctype --with-gd --enable-gd-native-ttf
--with-jpeg-dir=/usr --with-png --with-gmp --with-pgsql
--enable-shmop --enable-memory-limit --enable-shared
--disable-debug --with-zlib=/usr --disable-cgi
--disable-path-info-check --enable-safe-mode --with-openssl
--with-bz2 --enable-calendar --enable-exif --enable-ftp
--enable-sockets --without-mysql
This are Apache modules:
Server version: Apache/2.0.52
Server built: Oct 25 2004 18:59:00
Server's Module Magic Number: 20020903:9
Architecture: 32-bit
Server compiled with....
-D APACHE_MPM_DIR="server/mpm/prefork"
-D APR_HAS_SENDFILE
-D APR_HAS_MMAP
-D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
-D APR_USE_SYSVSEM_SERIALIZE
-D APR_USE_PTHREAD_SERIALIZE
-D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
-D APR_HAS_OTHER_CHILD
-D AP_HAVE_RELIABLE_PIPED_LOGS
-D HTTPD_ROOT="/usr/local/apache-server2"
-D SUEXEC_BIN="/usr/local/apache-server2/bin/suexec"
-D DEFAULT_PIDLOG="logs/httpd.pid"
-D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
-D DEFAULT_LOCKFILE="logs/accept.lock"
-D DEFAULT_ERRORLOG="logs/error_log"
-D AP_TYPES_CONFIG_FILE="conf/mime.types"
-D SERVER_CONFIG_FILE="conf/httpd.conf"
The php.ini changes:
precision = 14
y2k_compliance = Off
output_buffering = 4096
allow_call_time_pass_reference = Off
safe_mode_gid = On
highlight.*
;max_input_time = 60
memory_limit = 6M
error_reporting = E_ALL
display_errors = Off
log_errors = On
error_log = /(...)/apache2/logs/php.log
variables_order = "GPCS"
register_argc_argv = Off
post_max_size = 4M
magic_quotes_gpc = Off
upload_tmp_dir = /(...)/tmp
upload_max_filesize = 4M
;SMTP = localhost
;sendmail_from = me@localhost.com
session.cache_expire = 60
session.use_trans_sid = 1
Actual result:
--------------
Running "gdb httpd" gives:
GNU gdb 5.2
(...)
This GDB was configured as "i386-slackware-linux"...
(gdb) run -DSSL -e debug -k start
Starting program: /uxd/apache-server2/bin/httpd -DSSL -e
debug -k start
[Tue Oct 26 13:16:42 2004] [debug] mod_so.c(247): loaded
module include_module
[Tue Oct 26 13:16:42 2004] [debug] mod_so.c(247): loaded
module deflate_module
[Tue Oct 26 13:16:42 2004] [debug] mod_so.c(247): loaded
module log_config_module
[Tue Oct 26 13:16:42 2004] [debug] mod_so.c(247): loaded
module env_module
[Tue Oct 26 13:16:42 2004] [debug] mod_so.c(247): loaded
module ssl_module
[Tue Oct 26 13:16:42 2004] [debug] mod_so.c(247): loaded
module status_module
[Tue Oct 26 13:16:42 2004] [debug] mod_so.c(247): loaded
module info_module
[Tue Oct 26 13:16:42 2004] [debug] mod_so.c(247): loaded
module negotiation_module
[Tue Oct 26 13:16:42 2004] [debug] mod_so.c(247): loaded
module dir_module
[Tue Oct 26 13:16:42 2004] [debug] mod_so.c(247): loaded
module alias_module
[Tue Oct 26 13:16:43 2004] [debug] mod_so.c(247): loaded
module php4_module
Program exited normally.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=30563&edit=1
Thread (6 messages)