#30514 [Fbk->NoF]: expat not working
ID: 30514
Updated by: php-bugs@lists.php.net
Reported By: mswartz at itgs-presearch dot com
-Status: Feedback
+Status: No Feedback
Bug Type: Compile Failure
Operating System: Linux/Solaris
PHP Version: 5.0.2
New Comment:
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
Previous Comments:
------------------------------------------------------------------------
[2004-10-23 08:55:38] tony2001@php.net
Works fine here - no error at compile time and function exists (libxml2
is not installed at all).
------------------------------------------------------------------------
[2004-10-21 17:19:14] mswartz at itgs-presearch dot com
Description:
------------
I believe that there are issues with expat and php5. First I'm aware
that expat is no longer bundled and the flag --with-libexpat-dir is
deprecated.
But if I use the deprecated flag on some systems xml functions will
work at runtime. On other systems the following error occurs when
being configured
configure: error: libxml2 version 2.5.10 or greater required. This
error happens with the use of --disable-libxml.
Using the new flag --with-expat-dir there are no issues at compile time
on the solaris or linux system used but at runtime the following error
is produced:
Fatal error: Call to undefined function xml_parser_create()
Reproduce code:
---------------
command line with old flag:
./configure --prefix=$Prefix --with-mysql=$Prefix --with-curl=$Prefix
--with-apxs2=$Prefix/bin/apxs --with-gd --with-png-dir=$Prefix
--with-zlib --disable-debug --disable-libxml
--with-libexpat-dir=$Prefix --enable-shared --enable-dbase && make &&
make install
command line with new flag:
./configure --prefix=$Prefix --with-mysql=$Prefix --with-curl=$Prefix
--with-apxs2=$Prefix/bin/apxs --with-gd --with-png-dir=$Prefix
--with-zlib --disable-debug --disable-libxml --with-expat-dir=$Prefix
--enable-shared --enable-dbase && make
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=30514&edit=1
Thread (3 messages)