Bug #16629 Updated: php_flag not working and php_value strange behavior
| From: | sabiokah at videotron dot ca | Date: | Sat, 04 May 2002 05:43:54 +0000 |
| Subject: | Bug #16629 Updated: php_flag not working and php_value strange behavior | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-6895@lists.php.net to get a copy of this message | ||
ID: 16629
Updated by: sabiokah@videotron.ca
Reported By: katana@katana-inc.com
Status: Open
Bug Type: Apache2 related
Operating System: Windows XP
PHP Version: 4.2.0
New Comment:
got no error message by adding
<IfModule mod_php4.c>
php_flag register_globals on
</IfModule>
However.. it has no effect at all.
I tried to change the name for mod_php4.c to php4_module
,mod_php3.c,mod_php42.c but it seem that since with
apache2 we dont need to specify AddModule mod_php4.c
I dont know if its appache that doesnt go in the If Statement or if it
is the php module that ignore the
apache directive.
It only work with php_value outside the if statement.
as mentionned by katana.
Im using Linux-Apache2.0.35 with php4.2.0
Previous Comments:
------------------------------------------------------------------------
[2002-04-28 22:04:19] jmt@twilley.org
I also have this problem under FreeBSD with Apache 2.0.35 and
PHP/4.3.0-dev, and I have a working patch. I don't know where to sedn
it or how to attach it. If someone could email me where to send it,
I'll send it.
------------------------------------------------------------------------
[2002-04-26 17:47:09] rubberneck@wwisp.com
Same problem on Linux machine running apache 2.0.35 with FINAL release
of php 4.2.0
------------------------------------------------------------------------
[2002-04-24 17:11:42] henrik.gebauer@web.de
I have the same problem under Windows 98 SE (Apache 2.0.35) and the
FINAL RELEASE of PHP 4.2.0.
------------------------------------------------------------------------
[2002-04-16 05:50:15] pryde@oldworld.de
same here on win2k, php 4.2.0 rc4
------------------------------------------------------------------------
[2002-04-16 04:44:44] katana@katana-inc.com
I was attempting to modify register_globals value in my vhost config
file like i used to do with PHP 4.1.X + Apache 1.3:
php_value register_globals On / Off
It didn't work with PHP 4.2.0 RC/3 even if i didn't get any error
message (the value just didn't get changed)
i tried using php_flag register_globals On / Off, but i got an error
message when attempting to restart apache:
Invalid command 'php_flag', perhaps mis-spelled or defined by a module
not included in the server configuration
Same thing with php_admin_flag
I had to use php_value register_globals 1 / 0 to get it to work.
I'm running Apache 2.0.35 on Windows XP professional, with PHP 4.2.0
RC/3.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=16629&edit=1