ID: 30808
User updated by: michael dot caplan at lechateau dot ca
Reported By: michael dot caplan at lechateau dot ca
Status: Suspended
Bug Type: OCI8 related
Operating System: RHE 3
PHP Version: 5.0.2
Assigned To: tony2001
New Comment:
Uncommenting the oci_ping() call does the trick. Both persitant and
non persistant connection then work after an Oracle restart.
But your reply confuses me. Why a new ini option (you mean at compile
time?)? Shouldn't this be the default behaviour? And why should I
wait till PDO for a stable way to connect to Oracle? Shouldn't this
issue be resolved in the current PHP OCI8 function library?
Thanks,
Michael
Previous Comments:
------------------------------------------------------------------------
[2004-11-17 07:35:17] tony2001@php.net
Currently you have to uncomment oci_ping() call in _oci_open_server()
function (see ext/oci8/oci8.c, line 3048).
It was planned to add an ini option for that, but it seems that nobody
likes new ini options and I quess we'll take care about it in brand new
PDO OCI driver.
Personally I do not have any objections to adding new ini option, so
I'm marking this resport as suspended for the time present.
------------------------------------------------------------------------
[2004-11-16 20:41:22] michael dot caplan at lechateau dot ca
Description:
------------
Every evening, for whatever reason, our Oracle db (9.2.0) is restated.
After it is restarted, I am unable to build a connection with Oracle
from PHP untill Apache is restarted.
Whenever I do an ociplogon() or ocilogon() following an Oracle DB
restart, it fails but I am unable to get a description of the error.
Restarting Apache "fixes" the problem.
This problem is similar to bug #26829 except that it effects both
persistent and non persistent conneciton.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=30808&edit=1