#30872 [Fbk->Opn]: SAPI Problem
| From: | HellDesk at bigfoot dot com | Date: | Tue, 23 Nov 2004 13:56:57 +0000 |
| Subject: | #30872 [Fbk->Opn]: SAPI Problem | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-69370@lists.php.net to get a copy of this message | ||
ID: 30872
User updated by: HellDesk at bigfoot dot com
Reported By: HellDesk at bigfoot dot com
-Status: Feedback
+Status: Open
Bug Type: Apache2 related
Operating System: Solaris 8
PHP Version: 4.3.9
New Comment:
I have managed to resolve this problem myself. It turns out that they
build for apache 2.0.53 is a little screwy and doesn't copy some of the
include files across namely some of the apr include files, which when
php goes looking for them causes it to error.
I copied all the include files from apr and apr-util to the apache2
include directory and php compiled against it.
Thanks for your time.
Previous Comments:
------------------------------------------------------------------------
[2004-11-23 14:51:30] derick@php.net
Provide the error messages then... we can't guess!
Derick
------------------------------------------------------------------------
[2004-11-23 14:32:28] HellDesk at bigfoot dot com
It's a shared module, should load straight in, has done in the past
with Apache 2.0.50 and 2.0.51, although when installing 2.0.52 we
recompiled the php module to add some functionality.
I have recompiled the module however it refuses to compile against
apache 2.0.53.
------------------------------------------------------------------------
[2004-11-23 14:29:34] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself. For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system
is not the
appropriate forum for asking support questions.
Thank you for your interest in PHP.
Just recompile PHP.
------------------------------------------------------------------------
[2004-11-23 14:28:09] tony2001@php.net
Correct me if I'm wrong: you're trying to use with 2.0.53 PHP module
that was compiled for 2.0.52 ?
Why do you expect it to work then?
------------------------------------------------------------------------
[2004-11-23 14:22:31] HellDesk at bigfoot dot com
Description:
------------
When compiling php 4.3.9 against apache 2.0.53 an SAPI issue uncovers
itself, namely that there appears to be changes to the SAPI in 2.0.53
whereby PHP 4.3.9 will not work with it, the syntax error trying to
run a module that was built for 2.0.52 with 2.0.53 gives this.
httpd: Syntax error on line 151 of /usr/local/apache2/conf/httpd.conf:
Module "/usr/local/php-4.3.9/sapi/apache2handler/sapi_apache2.c" is not
compatible with this version of Apache (found 20020903, need 20040425).
Please contact the vendor for the correct version.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=30872&edit=1