Bug #17064 Updated: PHP + Sablotron will not load
| From: | rasmus@php.net | Date: | Tue, 07 May 2002 05:15:49 +0000 |
| Subject: | Bug #17064 Updated: PHP + Sablotron will not load | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-7110@lists.php.net to get a copy of this message | ||
ID: 17064
Updated by: rasmus@php.net
Reported By: leppert@insight.rr.com
-Status: Open
+Status: Feedback
Bug Type: XSLT related
Operating System: Linux, kernel 2.4
PHP Version: 4.2.0
New Comment:
Well, it compiled cleanly for me with the same versions of everything.
Could you point us at another report of this same thing from someone
else?
Previous Comments:
------------------------------------------------------------------------
[2002-05-07 01:11:55] leppert@insight.rr.com
This bug prevents the use of Sablotron, via the PHP XSLT extension.
Compiling PHP with Sablotron and XSLT support (--enable-xslt and
--with-xslt-sablot) is successful, however, when one attemps to load
the module into Apache, it does not load giving the following error:
Cannot load /usr/local/apache/libexec/libphp4.so into server: undefined
symbol: __gxx_personality_v0
apachectl start: httpd could not be started
It does not appear to be compiler related as I tried it with GCC 2.95.3
and 3.0.4. This does not appear to be an isolated problem, as there
have been several messages from others on USENET related to the
problem.
Configure:
--with-mysql --with-apxs --enable-xslt --with-xslt-sablot
Versions:
Apache: 1.3.24
Sablotron: 0.90
Expat: 1.95.2
PHP: 4.2.0 or 4.1.2
GCC: 2.95.3 or 3.0.4
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=17064&edit=1