Bug #16808 Updated: Unresolved symbol: __umoddi3 (code)

From: Date: Tue, 07 May 2002 23:36:15 +0000
Subject: Bug #16808 Updated: Unresolved symbol: __umoddi3 (code)
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-7182@lists.php.net to get a copy of this message
ID: 16808 Updated by: aaron@php.net Reported By: pbriggs@clinitech.net -Status: Open +Status: Bogus Bug Type: Apache2 related Operating System: HPUX 11.00 PHP Version: 4.2.0 New Comment: The bug system is not the appropriate forum for asking support questions. For a list of a range of more appropriate places to ask for help using PHP, please visit http://www.php.net/support.php This looks like a gcc problem. I've diagnosed problems with Solaris+gcc where gcc will include libgcc symbols in the object files but fails to tell the native linker (/usr/ccs/bin/ld on solaris) how to resolve those symbols. Therefore at runtime you get symbol resolution failures. Do you really have a shared version of libgcc? If so, is it in your library path? To link against libgcc.a statically, and as a minor workaround (since this is partly gcc's fault), try this: LDFLAGS="gcc -print-libgcc-file-name" ./configure --your-flags If you are still having this problem, please open a bug with mysql, as the unresolved symbol is coming from that object. Thanks for using Apache and PHP. Previous Comments: ------------------------------------------------------------------------ [2002-04-24 16:27:48] pbriggs@clinitech.net HP-UX 11.00 Binutils 2.12 GCC 3.0.4 GNU Make 3.79.1 mysql-3.23.49 (using GCC) ./configure --prefix=/opt/mysql Have verified -lgcc being used in mysql build. apache-2.0.35 (using GCC) ./configure --prefix=/opt/apache2 php-4.2.0 (using GCC) ./configure --prefix=/opt/php --enable-libgcc \ --with-apxs2=/opt/apache2/bin/apxs \ --with-mysql=/opt/mysql --enable-sockets Start Apache: /opt/apache2/bin/apachectl start Error: Syntax error on line 217 of /opt/apache2/conf/httpd.conf: Cannot load /opt/apache2/modules/libphp4.so into server: Unresolved symbol: __umoddi3 (code) from /opt/mysql/lib/mysql/libmysqlclient.sl.10 /opt/apache2/bin/apachectl start: httpd could not be started Everything has been compiled with GCC. Have used -enable-libgcc in PHP's compiling, but somehow I'm still having problems with this __umoddi3 not being resolvable. Patrick ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=16808&edit=1

« previous php.bugs (#7182) next »