#31667 [Opn]: md5_file fails on large files
| From: | markyd at optushome dot com dot au | Date: | Sun, 23 Jan 2005 11:49:51 +0000 |
| Subject: | #31667 [Opn]: md5_file fails on large files | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-72691@lists.php.net to get a copy of this message | ||
ID: 31667
User updated by: markyd at optushome dot com dot au
Reported By: markyd at optushome dot com dot au
Status: Open
Bug Type: Unknown/Other Function
Operating System: Linux Debian (SID)
PHP Version: 4.3.10
New Comment:
This code was running as part of a shell script and not via apache
(module or cgi)
Also the shell command md5sum works on the file the files that the code
above fails on.
Previous Comments:
------------------------------------------------------------------------
[2005-01-23 12:43:36] markyd at optushome dot com dot au
Description:
------------
It seems that the function md5_file() fails to operate on large files.
I believe this issue occurs when the file is larger that 2gb. Slightly
smaller files (around 1.8gig) seems to work fine.
When trying to access these large files, php generates the following
error:
Warning: md5_file(): Unable to open file in XXXXX on line XXX
Reproduce code:
---------------
md5_file("a_large_file");
Expected result:
----------------
return a valid md5hash
Actual result:
--------------
Warning: md5_file(): Unable to open file in XXXXX on line XXX
returns an empty string
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=31667&edit=1