#31907 [Opn->Fbk]: Problems with passive mode

From: Date: Sat, 12 Feb 2005 02:22:39 +0000
Subject: #31907 [Opn->Fbk]: Problems with passive mode
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-73918@lists.php.net to get a copy of this message
ID: 31907 Updated by: sniper@php.net Reported By: wolkove at biz-link dot com -Status: Open +Status: Feedback Bug Type: FTP related Operating System: FreeBSD 4.8 PHP Version: 4.3.8 New Comment: Please try using this CVS snapshot: http://snaps.php.net/php4-STABLE-latest.tar.gz For Windows: http://snaps.php.net/win32/php4-win32-STABLE-latest.zip Previous Comments: ------------------------------------------------------------------------ [2005-02-09 20:56:44] wolkove at biz-link dot com Description: ------------ I have a reproducible problem using passive mode with a particular remote server. Initially I set passive mode using ftp_pasv($conn, true) The function call returns false, indicating it could not set passive mode. Then I either continue with the transfer or (tried) setting passive mode to false with ftp_pasv($conn, false) and then continuing the transfer The transfer fails in either case. The remote firewall reports the following error in its logs: Attack Info: ftp address mismatch: ip_src != command_src message_info: Illegal port command (port = 0) Somehow it seems PHP is getting confused by the apparent failure to set passive mode and trying to use a PORT command to connect using an illegal port = 0. The failure to set passive mode is another mystery. When connecting manually using the FreeBSD ftp client from the same machine or a Windows client, the program has no trouble setting and using passive mode. ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=31907&edit=1

« previous php.bugs (#73918) next »