#32005 [Fbk->Opn]: Apache 1.3.33 unresolved symbols in DSO
| From: | agreenbu at nyx dot net | Date: | Thu, 17 Feb 2005 13:16:35 +0000 |
| Subject: | #32005 [Fbk->Opn]: Apache 1.3.33 unresolved symbols in DSO | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-74225@lists.php.net to get a copy of this message | ||
ID: 32005
User updated by: agreenbu at nyx dot net
Reported By: agreenbu at nyx dot net
-Status: Feedback
+Status: Open
Bug Type: Apache related
Operating System: Mac OS X 10.3.8
PHP Version: 5.0.3
New Comment:
This snapshot fixed the problem. Thanks!
Previous Comments:
------------------------------------------------------------------------
[2005-02-17 10:35:32] sniper@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php5-STABLE-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php5.0-win32-latest.zip
------------------------------------------------------------------------
[2005-02-16 22:59:27] agreenbu at nyx dot net
Description:
------------
After building PHP 5.0.3 as a DSO and enabling in httpd.conf, Apache
crashes on apachectl start with a crashdump, but no error messages.
If I disable the LoadModule and AddModule lines for php5 in httpd.conf,
and start Apache, it starts, and then if I re-enable php5 in httpd.conf
and run apachectl restart, it reloads with working PHP 5. This has
happened on previous releases of PHP 5 as well.
Reproduce code:
---------------
1. Build clean Apache 1.3.33 from source in /usr/local/apache.
2. Build PHP with settings:
./configure --prefix=/usr/local
--with-apxs=/usr/local/apache/sbin/apxs --with-curl=/usr/local
--with-zlib --with-mysql=shared,/usr/local/mysql --with-mysqli
--enable-soap --enable-sockets --with-openssl
make
make install
3. Enable PHP module in httpd.conf
4. Start Apache
/usr/local/apache/sbin/apachectl start
-- Should crash.
5. Disable PHP module in httpd.conf
6. Start Apache
/usr/local/apache/sbin/apachectl start
-- Should work.
7. Enable PHP module in httpd.conf
8. Restart Apache
/usr/local/apache/sbin/apachectl restart
-- Should work.
Expected result:
----------------
Apache should load the module on the first try.
Actual result:
--------------
I get the following crash dump when running apachectl start:
Link (dyld) error:
dyld: /usr/local/apache/sbin/httpd Undefined symbols:
_OnUpdateLong
_OnUpdateString
_OnUpdateStringUnempty
__array_init
__convert_to_string
__efree
__emalloc
__erealloc
__estrdup
__estrndup
__object_and_properties_init
__object_init
__object_init_ex
__safe_emalloc
__zend_get_parameters_array_ex
__zend_hash_add_or_update
__zend_hash_init
__zend_list_addref
__zend_list_delete
__zend_list_find
__zval_copy_ctor
__zval_ptr_dtor
_add_assoc_null_ex
_add_assoc_zval_ex
_add_index_long
_add_index_null
_add_index_zval
_add_property_long_ex
_add_property_string_ex
_ap_php_snprintf
_convert_to_array
_convert_to_boolean
_convert_to_double
_convert_to_long
_core_globals
_display_ini_entries
_display_link_numbers
_empty_string
_executor_globals
_get_active_function_name
_le_index_ptr
_php_addslashes
_php_error_docref0
_php_get_current_user
_php_info_print_table_end
_php_info_print_table_header
_php_info_print_table_row
_php_info_print_table_start
_php_set_error_handling
_php_sprintf
_zend_call_functi
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=32005&edit=1