Bug #17152 Updated: driver initialization failed in [script_name] on [line_num]
| From: | mfischer@php.net | Date: | Sat, 11 May 2002 20:08:36 +0000 |
| Subject: | Bug #17152 Updated: driver initialization failed in [script_name] on [line_num] | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-7451@lists.php.net to get a copy of this message | ||
ID: 17152
Updated by: mfischer@php.net
Reported By: dave@thinkhost.com
-Status: Open
+Status: Feedback
Bug Type: DBM/DBA related
Operating System: RedHat 7.2
PHP Version: 4.2.0
New Comment:
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php
Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.
Previous Comments:
------------------------------------------------------------------------
[2002-05-11 16:07:39] dave@thinkhost.com
Note the the above error (segfault) is encountered when the following
code is executed:
$dba = dba_open("./test.db", "r", "db2");
So the segfault is related to a different driver set
------------------------------------------------------------------------
[2002-05-11 16:04:29] dave@thinkhost.com
The problem has further degraded...
Insteading getting a PHP warning about driver init failure, the page
fails to load, and I am getting all kinds of these messages in HTTPD's
error_log that read:
[notice] child pid [PID] exit signal Segmentation fault (11)
I'm convinced that this is a problem with PHP.
------------------------------------------------------------------------
[2002-05-11 01:37:04] dave@thinkhost.com
When executing the following code:
<?php
echo "Starting...<BR>\n";
$dba = dba_open("./test.db", "r", "ndbm");
?>
The following error message is encountered:
Warning: driver initialization failed in
/var/www/devuser/devbox-mx.dhs.org/www/test/test.php on line 5
PHP 4.2.0 was compiled with the following command:
'./configure' '--with-apxs=/usr/sbin/apxs' '--with-mysql'
'--with-pgsql' '--with-config-file-path=/etc' '--enable-track-vars'
'--disable-short-tags' '--disable-posix' '--with-curl'
'--with-gettext'
'--with-ldap' '--with-zlib' '--with-dom' '--with-db'
'--with-gdbm=/usr/include/gdbm' '--with-ndbm=/usr/include/db1'
'--with-db2=/usr/include/db2' '--with-db3=/usr/include/db3'
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=17152&edit=1