Bug #12975 Updated: Unable to load dynamic library 'd:\applications\php\extensions\php_oci8.dll' -

From: Date: Mon, 13 May 2002 19:19:24 +0000
Subject: Bug #12975 Updated: Unable to load dynamic library 'd:\applications\php\extensions\php_oci8.dll' -
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-7553@lists.php.net to get a copy of this message
ID: 12975 Updated by: hnek@nepadresje.nep.nl Reported By: pbabilotte@multilignes.fr Status: Open Bug Type: IIS related Operating System: Windows 2000 Server PHP Version: 4.0.6 New Comment: Hello, I have similar problems on Win2k-server and WinXP when trying to get php_gd working. This dll-loading seems magical stuff. First I got this 'specified procedure'-error only at work. The configuration there: php_gd.dll/PHP4.0.6/IIS/Win2k. But I didn't have any problem at home with configuration: php_gd.dll/PHP4.0.6/Xitami/WinXP. So I tried to get me a new PHP-version, 4.2, to test with at home. And you won't believe it... with a configuration: php_gd.dll/PHP4.2/Xitami/WinXP, now I get the 'specified procedure'-error at home. By the way, I got rid of the 'module-not-found' by typing the right path c:/php/ex... with all foward-slashes. Once I was a happy php_gd-user. Now feel like a Windoze-looser. h e l p Mark Previous Comments: ------------------------------------------------------------------------ [2002-02-26 18:01:33] info@tmnd.de Hello, I also have a similar problem. I am using with php4ispi.dll with IIS5 Win2000 Prof.. I wrote my own extension in a dll. And it can load it, that means, I can run phpinfo() so that it shows my Extension. But I cannot run the functions which are implemented in this extension. And I also cannot run a simple application. ------------------------------------------------------------------------ [2002-01-16 12:43:06] habeck@gmx.de IMO it's not only the php_oci8.dll which cannot be loaded. I even (on windows-NT-system) could not load for example the php_dbg.dll, php_pdf.dll extensions with PHP 4.1.1. May be someone can test this for other extensions to find out if this is a general bug on windows-systems. Can someone help? Thanks Klaus Habeck ------------------------------------------------------------------------ [2001-08-27 09:15:25] pbabilotte@multilignes.fr I install PHP 4.0.6 with IIS 5 and it did install find. I did modify my php.ini. I did create a test page and then it says : Unable to load dynamic library 'd:\applications\php\extensions\php_oci8.dll' - The specified module could not be found And it write the same thing on my server I have installed php on : d:\applications\php and the extension are located on d:\applications\php\extensions I have double check the extension_dir What do i have to do to make it works??? Thanks Philippe BABILOTTE What do i have to do ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=12975&edit=1

« previous php.bugs (#7553) next »